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Verification Setup

Diab Compiler Support: Set up Polyspace verification easily for code
compiled with Wind River Diab compiler

If you build your source code using the Wind River® Diab compiler, in R2016b, you can

easily set up a Polyspace® project to verify your code. After you specify the Diab compiler
and your target processor, the verification:

* Implicitly defines all macros that are defined for the Diab compiler. Previously, you
defined the macros in your Polyspace project explicitly to avoid compilation errors.

+  Understands language extensions such as keywords and pragmas that are specific to
the Diab compiler. Previously, you removed unknown language extensions explicitly
from the preprocessed code in your Polyspace project to avoid compilation errors.

You can now set up a Polyspace project manually without knowing the internal workings
of your Diab compiler. Specify the Diab compiler and your target processor, and run
verification without facing compilation errors. See Diab Compiler (-compiler diab).

The software supports version 5.9 and older versions of the Diab compiler.

Multitasking Code Verification Setup: Specify cyclic tasks and
nonpreemptable interrupts directly as verification options

In R2016b, you can specify which entry points in your code represent cyclic tasks and
nonpreemptable interrupts. Previously, to emulate the cyclic behavior of a task, you
embedded instructions in a loop. To emulate a nonpreemptable interrupt, you specified
temporally exclusive pairs where the interrupt was paired with all other interrupts.

For more information, see Cyclic tasks (-cyclic-tasks) and Interrupts (-interrupts).

Improved source and include folder management

Before R2016b, when you created a project, you added and removed source files and
include folders individually. If you moved your source files or added new files to your
programming project, you re-added the files into your Polyspace project.

Starting in R2016b, you create Polyspace projects with root source folders and include
folders. The root folder location represents the top of the hierarchy for your source files.
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Polyspace shows all files relative to the root source locations. When you add a root source
location, you can:
*  See all source files under the root folder (and subfolders)

+ Exclude files and subfolders in the hierarchy to change the active list of source files to
analyze.

+ Refresh the source file list to see new files or folders in the root source hierarchy.
*  Modify the root source folder path.

+ If you use a revision control system, change the root folder location to point to
different versions of your source files.

For include folders, instead of adding individual folders, you add a root include folder
location. Polyspace adds all include folders underneath the root include location that
contains include files. You can refresh and modify the include folder path.

For more information, see “Create Project”.

Writable Examples: Modify example projects and restore original
versions

The examples projects under Help > Examples are now easier to use. The

first time that you open an example project, a writable version is saved in your
Polyspace Workspace. In the writable project, you can test configuration options,
change sources, and rerun the example. If you want to refresh the example with a clean
version, select Help > Examples > Restore Default Examples.

Run verification on . psprj file from the command line

If you already have a project created in the Polyspace Interface, you can now use that
-psprj file to run your verification from a command line.

DOS or UNIX Command Line

Use the new option polyspace-code-prover -generate-launching-script-for
<PSPRJ FILE> to generate the files to run the analysis from the command line. These
files are generated:

* source_command.txt — List of source files in the project
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+ options_command.txt — List of analysis option settings

* launchingCommand.sh or launchingCommand.bat — Script that runs the
verification using options_command . txt, source_command.txt. The script can
also take additional analysis options as parameters.

For more information, see “Create Command-Line Script from Project File”.

MATLAB Command Prompt

At the MATLAB® command prompt, you can now give a .psprj file as an argument to
polyspaceCodeProver.

The syntax polyspaceCodeProver(PSPRJ file, "nodesktop™) runs a verification
on the project. If you have multiple modules or configurations, the active module and
active configuration are verified.

Polyspace APl in MATLAB: Configure and run Polyspace using MATLAB
objects

In R2016b, Polyspace scripting from MATLAB is easier and more MATLAB-friendly.
R2016Db introduces a set of classes, methods, and function improvements to help you run
Polyspace from MATLAB. For more information and examples, see the linked reference

pages.

Classes
Name Description
polyspace.CodeProverOptions An options object with properties that map to the

Polyspace environment configuration options. Use this
object to customize analysis options and run analysis.

polyspace.ModelLinkCodeProverOptiong Another version of the CodeProverOptions object with

properties specifically for model generated code. Use this
object to customize analysis options and run analysis.

polyspace.GenericTargetOptions A helper object for the CodeProverOptions classes. Use

this object to customize a generic target.

polyspace.CodingRulesOptions A helper object for the CodeProverOptions object. Use

this object to customize the list of coding rules checked
during the analysis.
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Methods

Name Description

polyspace.Options.copyTo Copy settings between options objects. You can use this
method to copy options from a CodeProverOptions
object to a BugFinderOptions object and vice versa.

polyspace.Options.generateProject Generate a . pspr] file from an options object to open in
the Polyspace interface.

Functions

Name Description

polyspaceCodeProver Run an analysis using CodeProverOptions objects or
-psprj files.

Configuration Parameters Help: View descriptions of Polyspace options in
Simulink configuration parameters

When you use the Simulink® plugin, you must set Simulink configuration parameters
to run your analysis. If you need help setting the configuration parameters, you can
now right-click a configuration parameter and get What”s This help. When you select
What’s This, a help window opens with details about the different settings and
limitations of the parameter.

For more information about the configuration parameters, see “Configure Code

Verification”.

Eclipse Build Support: Set up Polyspace verification from Eclipse build
command

In R2016b, if you use a build command to build your source code in Eclipse™ or an

IDE based on Eclipse, you can easily set up your Polyspace verification. To obtain the
necessary compiler options for the verification, trace the build command inside the IDE.
For more information, see “Configure Verification”.

Visual Studio 2010 add-in support to be removed from installation

In a future release, the Polyspace add-in for Visual Studio® 2010 will no longer be
included with the installation.
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To run Polyspace on code from Visual Studio, use the automatic configuration tool
instead. See “Create Project Using Visual Studio Information”.

If you still want to use the add-in, you will be able to download the add-in from MATLAB
Answers.

Support for Rhapsody 8.1

Starting in R2016b, the Polyspace plugin for IBM® Rational® Rhapsody®™ supports
Rhapsody 8.1. For more information, see “Verify Code in IBM Rational Rhapsody
Environment”.

DOS Mode Warning on Linux: Compilation warning for DOS
inconsistencies

When using Polyspace on Linux®, a new compilation warning may appear. On Windows",
DOS is case-insensitive meaning you cannot have two files with the same name

but different capitalization. If you select the option Code from DOS or Windows file
system (-dos)Code from DOS or Windows file system (-dos), Polyspace simulates this
DOS behavior on Linux. If your source files include header files with inconsistent
capitalization and it is unclear which file should be included, Polyspace issues a
compilation warning.

For example, consider these two situations:

Include Statements Include Files

Situation 1 #include ""myheader.h" myheader .h
#include ""MYHEADER.h"
#include '"'"MyHeader.h"

Situation 2 #include "myheader.h" myheader.h
#include ""MYHEADER.h" MYHEADER . h
#include ''"MyHeader.h"

In the first situation, only one file exists with the name myheader .h. Because these
include statements can only refer to one file, there is no ambiguity about which file to
include. No warning is issued.

In the second situation, two files exist: myheader.h and MyHeader . h. Because they
have the same name and different capitalization, the capitalization in the include
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statement affects which file is included. Polyspace can find perfect matches for the
first and second include statements. The last include statement is not a perfect match,
so could refer to either header file. Because there is ambiguity with the last include
statement, Polyspace issues this compilation warning: warning: could not find
include file "MyHeader.h".

In a future release, this compilation warning will become a compilation error.

Faster Restart for Remote Verification: Reuse compilation results from a
previous analysis

In R2016Db, if a remote verification stops after compilation, for instance because of
communication problems between the server and client computers, you do not have to
restart the verification from the beginning. You can reuse compilation results from the
previous failed analysis.

For more information, see —submit-job-from-previous-compilation-results.

Internal Memory Limits Removed: Expect fewer analysis failures from
memory-intensive processes

In R2016b, several internal limits on memory usage have been removed. Previously, if
certain processes consumed memory above a certain limit (around 5 GB per process),
those processes were stopped and the overall analysis failed. Now you are less likely to
see failures from memory-intensive processes.

If you were unable to complete analysis on large or complex projects because of failures
from memory-intensive processes, you are more likely to succeed in R2016b.

Support for local threads

Starting in R2016b, Polyspace adds support for these local thread modifiers:

+ _ thread — requires Compiler (-compiler) gnu4 .8
+ _ declspec(thread) — requires Compiler (-compiler) visual
+ thread_local — only for C++ code.

This support may eliminate compilation errors or change variable from shared to non-
shared.
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Changes in Target & Compiler analysis options

In R2016b, these Target & Compiler options have been added, changed, or removed.

Option Change More Information
Compiler (-compiler) |New option
Dialect (-dialect) |Removed Option will be permanently removed in a future
from release.
the user
interface. Replace -dialect with -compi ler while
retaining the option argument. In the user
If you use interface, this replacement is done automatically

the option in
your scripts,

for existing projects.

If you use the Wind River Diab compiler to build

you see a
warning. your source code, use the option Compiler (-
compiler) with argument diab.
Target processor type |Updated for |In the user interface, if you select diab for
(-target) the Wind Compiler (-compiler), you see target processors
River Diab  |that are tailored to the Diab compiler. For the
compiler. processor specifications, see the contextual help.
Target operating Removed Option will be permanently removed in a future
system (-0S- from release.
target) the user
interface. Remove the option from your scripts. For some
option arguments, you might have to perform
If you use these additional steps:

the option in
your scripts,
you see a
warning.

* Linux: If you get compilation errors, use a
gnux. x argument for Compiler (-compiler).

Sometimes, you might have to explicitly define
operating-system-specific macros such as
linux, unix, or ___Iinux__ . See Preprocessor
definitions (-D).

+ Visual: Use a visualx. x argument for
Compiler (-compiler).

vxworks: Use the options from the VxWorks®
templates.
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Option Change

More Information

Create a Polyspace project using one of the
VxWorks templates and generate a script
from your project. Copy the options related to
the VxWorks template from this script. For
more information, see “Create Project Using
Configuration Template” and the reference
page for —-generate-launching-scripts-
for.

+ Solaris: Just remove the option -0S-target.

* no-predefined-0S: Just remove the option -
0S-target.

Changes in analysis options and binaries

In R2016b, these options have been added, changed, or removed.

For changes to Target & Compiler options, see “Changes in Target & Compiler analysis
options” on page 1-8. For all other options, see the following table.

New Options

Option

Description

Cyclic tasks (-cyclic-tasks)

Specify functions that represent cyclic tasks.

Interrupts (-interrupts)

Specify functions that represent nonpreemptable
interrupts.

Consider environment pointers
as unsafe (-stubbed-pointers-are-
unsafe)

Specify that stubbed pointers coming from external
code can be unsafe unless otherwise constrained.

Consider volatile qualifier on

fields (-consider-volatile-qualifier-
on-fields)

Consider that structures with volati le-qualified
fields can change between consecutive accesses.

Subnormal detection mode (-
check-subnormal)

Detect operations that result in subnormal floating
point values.

Generate stubs for Embedded
Coder lookup tables (-stub-

Stub autogenerated functions that use lookup tables
and model them more precisely.
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Option

Description

embedded-coder-lookup-table-
functions)

-preemptable-interrupts

Specify functions that represent preemptable
interrupts.

-non-preemptable-tasks

Specify functions that represent nonpreemptable
tasks.

-function-behavior-specifications

*  Map your library functions to standard library
functions recognized by Polyspace.

+ Specify functions that contain lookup tables with
linear interpolation and no extrapolation.

-submit-job-from-previous-
compilation-results

Specify that the analysis job must be resubmitted
without recompilation.

Updated Options
Option Change  |More Information
Detect stack pointer dereference |Option
outside scope (-detect-pointer- now
escape) available
in user
interface.
Coding rule subsets single- Subsets |These subsets are available for Check

unit-rules and system-

now MISRA C:2004 (-misra2), Check MISRA

decidable-rules available |AC AGC (-misra-ac-agc), and Check
in the MISRA C:2012 (-misra3)
Polyspace
interface.

-check-infinite and -check-nan Option Use warn-Ffirst as option argument

argument |instead of warn.
renamed.

Removed Options
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Option Status More Information

Green absolute address Error Absolute address usage checks are green

checks (-green-absolute- by default. To remove this assumption

address-checks) and produce an orange check, use
the option -no-assumption-on-
absolute-addresses.

Files and folders to ignore (- |Error Use the option Do not generate results

includes-to-ignore) for (-do-not-generate-results-
for) to suppress results from headers
and sources in certain files or folders.

Ignore float rounding (- Error Option will be removed in a future

ignore-float-rounding) release.

-retype-pointer Error Option will be removed in a future
release.

-retype-int-pointer Error Option will be removed in a future
release.

—-lwtm Error Option will be removed in a future
release.

-support-FX-option-results|Error Option will be removed in a future
release.

polyspace-vcproj Removed |Use polyspace-configure or the
Polyspace Add-In for Visual Studio
instead.

polyspace-automatic- Warning |Binary will be removed in a future

verification release.

polyspace-verifier Warning |Binary will be removed in a future
release.

rte-kernel Warning |Binary will be removed in a future
release.

polyspace-remote Warning |Binary will be removed in a future
release.

Import folder (-import-dir) |[Warning |Option will be removed in a future

release.
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Option Status More Information

No automatic stubbing (-no- |Warning |Option will be removed in a future

automatic-stubbing) release.

-easy-setup-preprocess Warning |Option will be removed in a future
release.

gui-api Warning |Binary will be removed in a future

release.
Use polyspace-comments-import
instead.

Compatibility Considerations

If you use scripts that contain the removed or updated options, change your scripts

accordingly.
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Verification Results

Subnormal Float Detection: Identify loss of precision from operations that
lead to subnormal results

In R2016b, the verification detects operations that result in subnormal floating-point
values. The presence of subnormal numbers indicates loss of significant digits. This loss
can accumulate over subsequent operations and eventually result in unexpected values.
Subnormal numbers can also slow down the execution on targets without hardware
support. If you run a Polyspace verification, you can choose to see one of the following:

+ All operations that lead to subnormal results.

*  Only those operations that lead to subnormal results from normal operands.

For instance, the numbers MIN_FLOAT and nextabove(MIN_FLOAT) are normal, but
their difference is subnormal.

For more information, see:
*  Subnormal detection mode (-check-subnormal): The option to specify subnormal

detection.

*  Subnormal float: The result of subnormal detection.

Local Variable Size Estimation: Find total size of local variables in a
function

In R2016b, you can compute the total size of local variables in a function by using these
two metrics:

+ Lower Estimate of Local Variable Size: Total size of local variables taking nested
scopes into account.

If a function has variable definitions in nested scopes, the software computes the
total variable size in each scope and uses whichever total is greatest. For instance,
if a conditional statement has variables definitions, the software computes the total
variable size in each branch, and then uses whichever total is greatest.

* Higher Estimate of Local Variable Size: Total size of all local variables.
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Changes to coding rule checking

Expanded MISRA C++ Support

The following MISRA C++:2008 rules are now supported.
* 0-1-9: There shall be no dead code.

* 0-1-11: There shall be no unused parameters (named or unnamed) in nonvirtual
functions.

* 0-1-12: There shall be no unused parameters (named or unnamed) in the set of
parameters for a virtual function and all the functions that override it.

* 0-2-1: An object shall not be assigned to an overlapping object.
* 16-6-1: All uses of the #pragma directive shall be documented.

Updated Specifications

The Polyspace specifications for these rules have been updated.

Standard Rule Change

MISRA C++:2008 2-10-3 The violation is on the second instance of the
duplicate identifier instead of the first.

2-10—4 The violation is on the second instance of the
duplicate identifier instead of the first.

5-0-3 If two types have the same size in the target
configuration, Polyspace no longer raises a violation.
5-0—-6 If two types have the same size in the target
configuration, Polyspace no longer raises a violation.
5-0-8 If two types have the same size in the target
configuration, Polyspace no longer raises a violation.
MISRA C:2004 and 5.3 The violation is on the second instance of the
MISRA AC AGC duplicate identifier instead of the first.
5.4 The violation is on the second instance of the

duplicate identifier instead of the first.

10.1 If two types have the same size in the target
configuration, Polyspace no longer raises a violation.

10.2 If two types have the same size in the target
configuration, Polyspace no longer raises a violation.

1-14



Verification Results

Standard Rule Change
10.3 If two types have the same size in the target
configuration, Polyspace no longer raises a violation.
10.4 If two types have the same size in the target
configuration, Polyspace no longer raises a violation.
MISRA C:2012 5.3 The violation is on the second instance of the

duplicate identifier instead of the first.

5.4 The violation is on the second instance of the
duplicate identifier instead of the first.

10.3 If two types have the same size in the target
configuration, Polyspace no longer raises a violation.

10.6 If two types have the same size in the target
configuration, Polyspace no longer raises a violation.

10.7 If two types have the same size in the target
configuration, Polyspace no longer raises a violation.

10.8 If two types have the same size in the target
configuration, Polyspace no longer raises a violation.

Metrics for C++ Templates: View code complexity metrics for instances of
C++ templates

In R2016b, you can compute code complexity metrics for C++ templates. If you
instantiate a C++ template function and specify the option Calculate code metrics (-code-
metrics), you now see function metrics for the template in your analysis results.

The metrics appear on the template definition. The software uses the first instance of the
template to calculate the metrics. If you specialize a template, you see separate metrics
for the original template and its specialization.

For more information, see “Code Metrics”.

Mutual Exclusion Support: View precise ranges for shared variables
protected by critical sections and temporally exclusive tasks

In R2016b, run-time error checking of multitasking code uses the protections that
you specify. Previously, the software used your specifications to determine only if the
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protections were sufficient and all shared variables were protected from concurrent
access by multiple tasks. However, the run-time error checking did not consider these
protections and assumed that a shared variable had all possible values as if it was

concurrently accessed.

In R2016b, improved support for protections reduces the number of orange checks from
overapproximation and narrows down the scope of your review. You can protect shared
variables from concurrent access through mutual exclusion of certain code sections. To
implement mutual exclusion, you use either multitasking primitives that the verification
can interpret or explicitly specify critical sections and temporally exclusive tasks.

The following example illustrates the change. For a more detailed tutorial, see “Manually
Protect Shared Variables from Concurrent Access”.

Prior to R2016b

R2016b

In the following code, if you specify that
task and interrupt_handler are
temporally exclusive, the shared variable
shared_var is protected from concurrent
access. However, the Overflow check on
the addition shared var += 2; does
not consider this protection. The check is
orange because the verification considers
that the addition can directly follow the
assignment shared_var = INT_MAX;.

#include <limits._h>
int shared_var;

void inc(Q {
/* Orange overflow */
shared_var += 2;

}

void reset() {
shared_var = 0;
b

void task() {
volatile int randomValue = 0;
while(randomvValue) {

In the following code, the Overflow
check on the addition considers the
temporal exclusion of task and
interrupt_handler. The check is green
because the verification considers that
the addition cannot directly follow the
assignment shared_var = INT_MAX;.
The assignment shared_var=0 takes
place in between the two operations.

#include <limits_h>
int shared_var;

void inc(Q) {
/* Green overflow */
shared_var+=2;

}

void reset() {
shared_var = 0;
by

void task() {
volatile int randomValue = 0O;
while(randomvValue) {
reset();

incQ;
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Prior o R2016b R2016b
reset(); incQ;
incQ; }
incQ; }
}
} void interrupt() {
shared_var = INT_MAX;
void interrupt() { }
shared _var = INT_MAX;
} void interrupt_handler() {
volatile int randomValue = O;
void interrupt_handler() { while(randomvValue) {
volatile int randomValue = O; interrupt();
while(randomvValue) { }
interrupt(Q); }
}
} void main(Q) {
}

void main() {

}

If the shared variable is a pointer or an array, this change in behavior does not occur.
Run-time error checking on shared pointers and arrays does not consider the protections.

Compatibility Considerations

If you use protections such as critical sections and temporal exclusion of tasks, you can
see a reduction from previous releases in the number of orange checks.

Improved Embedded Coder Support: View more precise results when
generated code uses lookup tables or large data structures

Lookup Tables

In R2016b, the verification assumes more precise return values for generated functions
that use a lookup table in their body. If your model has Lookup Table blocks, such
functions are generated . Previously, the software assumed full range for the return
values of those functions. To avoid orange checks from this overapproximation, for
certain kinds of lookup tables, the software now assumes that the function return
values are within the bounds of the lookup table. The software makes this assumption
only if the lookup table in the function uses linear interpolation and does not allow
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extrapolation. For more information, see Generate stubs for Embedded Coder lookup
tables (-stub-embedded-coder-lookup-table-functions).

If the software does not detect functions that use lookup tables of this kind, you can also
explicitly specify such functions. For instance, if you use a lookup table function in an
S-Function block, the function name might not adhere to the naming convention for
lookup table functions. If the software assumes full range for its return value, you can
explicitly specify that the function uses a lookup table with linear interpolation and no
extrapolation. For more information, see -function-behavior-specifications.

Large Data Structures Accessed Via Pointers

In R2016b, when your code has a large global data structure and a function accesses its
fields via pointers, the verification is more precise than before. Previously, if a function
modified one field via pointers, in some cases, the verification lost precision on other
fields and assumed full range for their values.

Code generated from models can have large structures because all inputs to or outputs
from the model are placed in one structure. With this improved precision, you can see
more precise results for generated code in many cases.

Compatibility Considerations

If you run verification on generated code, you can see a reduction from previous releases
in the number of orange checks.

Precise Buffer Manipulation Functions: View more precise results on
complete copying of structures

In R2016b, if your code uses the memcpy, memmove, or bcopy function to copy structures,
you can see fewer orange checks. Previously, if you copied one structure to another with
these functions, the software assumed that each field of the destination structure had full
range of values. The software now considers precise values for the result of the copy.

Assumption for Stubbed Pointers: Review fewer warnings from pointers
coming from external code

In R2016b, the default verification for C code assumes that stubbed pointers coming from
external code are safe. For instance, the pointer does not have a NULL value and pointer
dereference is within allowed bounds.
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Previously, the default verification assumed that stubbed pointers were unsafe. For
instance, if you dereferenced the pointer return value of a stubbed function without
checking for NULL, the Illegally dereferenced pointer check showed a warning in
orange. With the change in default assumption, orange Illegally dereferenced pointer
checks in your verification results are more likely to have a root cause within your code.

Compatibility Considerations

If you run verification on a Polyspace project from a previous release, you can see a
reduction in the number of orange checks.

You can also see an increase in the number of gray checks. If your code contains
protections against NULL values of environment pointers, for instance conditions such as
iT(ext_ptr!=NULL), a gray check appears on these protections.

To revert to the previous default assumption, use the option Consider environment
pointers as unsafe (-stubbed-pointers-are-unsafe). Alternately, you can individually
change the default assumption on certain pointers only in the Constraint Specification
window. See the description for Initialize Pointer in “Constraints”.

Assumption for Structures with Volatile Fields: Review fewer warnings
from partly volatile structures

In R2016b, the default verification ignores the volati le qualifier on fields of a
structure. Previously, if a structure had a volati le-qualified field, the verification
considered all fields of the structure as volatile. As a result, the verification assumed that
their values always spanned the full range of their data types. This overapproximation
sometimes caused false warnings in orange from the non-volati le fields.

If you use a structure whose fields represent values read from hardware, add the
volati le qualifier to the structure definition instead of individual field definitions.

Compatibility Considerations

If you run verification on a Polyspace project from a previous release, you can see a
reduction in the number of orange checks. Occasionally, you can also see changes in red
or gray checks. For instance, if the field structlnstance.field is volatile, branches
of the condition if(structlnstance.field) were previously always reachable. With
the new assumption, depending on the value of structlnstance.field, some of the
branches can be unreachable.
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To revert to the previous default assumption, use the option Consider volatile qualifier on
fields (-consider-volatile-qualifier-on-fields).

Expected Infinite Loop Detection: Avoid justifying run-time errors on
infinite loops that you introduce deliberately

In R2016b, the verification detects if an infinite loop is intentional. For these infinite
loops, the verification does not produce a red Non-terminating loop error on the loop
statement. If you deliberately introduce infinite loops, for instance, to emulate cyclic
tasks, you do not have to justify red checks. For example, if a loop has a trivial predicate
while(1) and there are no exit statements in the loop body, the verification considers
the loop as intentional.

For more information, see Non-terminating loop.

Compatibility Considerations

If you run verification on a pre-R2016b project, you see a reduction from previous
releases in the number of red Non-terminating loop checks. However, as in previous
releases, any code following the infinite loop shows gray checks. Though the infinite loop
is expected, the verification considers code following the infinite loop as unreachable.

Mapping to Standard Functions: View precise results by mapping
imprecisely analyzed functions to corresponding standard functions

In R2016b, if you encounter imprecisions in analysis of your custom library function, you
can map the function to a standard library function for more precise analysis.

Polyspace Code Prover™ cannot analyze certain code constructs because of inherent
limitations with static verification. If your custom library function uses one of those
constructs, to avoid missing a run-time error, the verification assumes all possible results
from the function call. To avoid orange checks from this overapproximation, you can

map your custom library function to a standard library function. Although the software
does not analyze the body of your library function, in the various call sites, the software
emulates your function behavior more precisely. For instance, the software assumes a
more precise range for the function return value. The reason for this precise analysis is
that the software models effects of standard library functions extremely precisely.

For instance:
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+ If you have an implementation of a trigonometric function and the software assumes
full range for the return value, map your implementation to the corresponding
standard library trigonometric function.

+ If you have a function that copies contents of one memory location to another and the
software assumes that the destination location is still uninitialized, map your function
to the memcpy function.

You can map to only certain standard library functions from math.h and copying
functions such as memcpy. Additionally, you can map your functions to some internal
Polyspace functions for more precise analysis. For more information, see -function-
behavior-specifications.
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Reviewing Results

Interactive Graphical Display: Click graphs on Dashboard to filter results

In R2016b, you can narrow down the scope of your review by using a graphical display

of analysis results. Previously you used the graphs to obtain an overview of the analysis
results and determine which results to focus on. Now you can also select elements in the
graphs to view only those results that you want to focus on. To see all results again, clear
your filters in one click.

To filter results, use the following graphs:
*  Check distribution: If you click a colored region on this pie chart, the Results List
pane shows checks of that color only.

* Top 5 coding rule violations: If you click a column corresponding to a rule, the
Results List pane shows violations of that rule only.

+ Top 5 orange sources: If you click a column corresponding to an orange source, the
Results List pane shows orange checks caused by that source only.

For more information, see “Filter and Group Results”.

Float Range Display: View float variables with narrow ranges more
clearly

In R2016b, the tooltips on float variables show an improved display of the variable
ranges. For instance:

+ If the lower and upper bounds of a float variable are close, the tooltip displays as
many digits as necessary to distinguish between them.

* The tooltips clearly indicate which values are shown with rounding. For instance,
the value 1.0 does not involve rounding but 1.2345_ _ . shows a variable that is
displayed with rounding towards zero.

When rounded, at least 5 significant digits are displayed.

For more information, see “Source”.
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Event History for Coding Rules: Navigate easily between two locations in
code that together cause a rule violation

In R2016b, for certain coding rules, the Result Details pane shows previous events
causing the rule violation. You can click an event and navigate to the corresponding
location in the source code.

¥ MISRA C:2012 5.1 {Required) 2/
External identifiers shall be distinct.
External variable engine_temperature_scaled conflicts with the external identifier engine_temperature_raw (file.c line 1).

Event File Scope Line

1 Violation site file.c file.c 1
MISRA C:2012 5.1 file.c

This event history is shown for those rules which are related to more than one location in
the code. For instance, the event history appears for the following rules:

MISRA C®:2004 Rule 5.2: Identifiers in an inner scope shall not use the same name as
an identifier in an outer scope, and therefore hide that identifier.

+ MISRA C:2012 Rule 5.1: External identifiers shall be distinct.
* MISRA® C++ Rule 2-10-1: Different identifiers shall be typographically unambiguous.

JSF® C++ Rule 139: External objects will not be declared in more than one file.

Subcheck Display for Standard Library Routines: Determine easily from
visual inspection which subcheck failed

The Invalid use of standard library routine check consists of multiple subchecks.
In R2016b, you can determine visually from the Result Details pane which subchecks
failed.

If a subcheck passes, it is marked with a ¥
+ If a subcheck fails in all the cases that the verification considers, it is marked with a
]

If a subcheck fails only in some of the cases, it is marked with a Z.
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For instance, in the following example, the first subcheck passed but the second one
failed.

! ID 22: Invalid use of standard ibrary routine 2/
Error: function 'memcpy’ is called with invalid argument(s)
» Checks on first argument (destination):
¥ Mot null.
1 Is not a memory area that is accessible within the boundary given by the third argument.

In the following example, the subchecks on the first argument passed but the first
subcheck on the second argument failed sometimes.

ID 31: Invalid use of standard fibrary routine 2/
Warning: function 'memcpy' is called with possibly invalid argument(s)
= Checks on first argument (destination):

¥ Mot null.

¥ Is a memory area that is accessible within the boundary given by the third argument.
= Checks on second argument (source):

? May be null.

¥ Is a memory area that is accessible within the boundary given by the third argument.
This check may be a path-related issue, which is not dependent on input values

Results from Macros: Coding rule violations highlighted on macro
definitions instead of macro instances

When you run coding rules checking, violations from macro definitions can propagate
throughout your code causing many results. In R2016b, coding rule violations caused by
a macro are now highlighted on the macro definition. This change reduces the number of
coding rule violations with the same root cause, simplifying your review process.

Verification Objectives in Eclipse: Create review scopes to focus your
review

From the Eclipse plugin, you can now create custom review scopes. Review scopes filter

your results to only the run-time checks, coding rules, or code metrics that you want to
see. For more information, see “Limit Display of Results”.
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Filtered Report: Reuse result filters for generated report

In R2016b, if you apply filters to your results, you can reuse those filters for the
generated report. For instance, you can use filters to view only the following subset of
results on the Results List pane and then reuse those filters for the report.

* View only critical checks (red, gray, and critical orange) and create a report with those
checks only.

*  View only new results found since the last analysis and create a report with the new
results only.

*  View only code metrics that exceed specified thresholds and create a report with those
metrics only.

On the Results List pane, you can apply complicated filtering criteria to show only the
results that are most meaningful to you. You can reuse these criteria for your generated
report and show only the results that you want the report reviewer to focus on. For more
information on the filters you can use, see “Filter and Group Results”.

The report shows which filters you have applied. Another person reviewing your report

can see your filtering criteria.

Results Export: Export results to text file for computing graphs and
statistics

In R2016b, you can export your results to a tab delimited text file. You can parse the text

file by using MATLAB or Excel® and generate graphs or statistics about your results
that you cannot readily obtain from the user interface. For instance, for each check type
(Division by zero, Overflow), you can calculate how many checks are red, orange, or
green.

For more information, see “Export Results to Text File”.
Coding Rule Graphs in Report: View breakdown of coding rules
violations by rule number and file

In R2016b, if you choose to report coding rule violations, the report contains two new
graphs.

* The first graph shows the number of coding rule violations broken down by file.
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single_file_analysis.c
example.c

main.c
initialisations.c
tasksic

tasks2.c

Mumberofrules

* The second graph shows the number of violations broken down by rule number.

10.3

8.1
177
18.1

41
10.4
15.6
13.2
14.4
17.2

MNumberofrules

Constraints in Report: Add comments about external constraints and view
comments in report

In R2016b, when you specify external constraints for verification and add comments

in the Constraint Specification window, the comments appear in the generated report.
Another person reviewing your report can see your comments. You can use the comments
to provide explanations for your constraints.

The constraints, along with your comments, appear in the report appendix that lists your
verification options.

For more information, see:

+ “Constraints”
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+ “Generate Report”

English Reports in Non-English Locales: Generate English reports on
operating systems with a different language

In R2016b, even if your operating system has a display language (Windows) or locale
(Linux) other than English, you can generate English reports. See “Generate Report
After Verification”.

Improved PDF report generation

In R2016b, the generation of PDF reports is improved.

+ The report generation is faster. For large results, the report generation is much less
likely to cause out-of-memory errors.

* The reports use an improved visual display.

Change in report template location

The location of the report template files has changed to matlabroot/toolbox/
polyspace/psrptgen/templates. Here, matlabroot is the MATLAB installation
folder.

If you use the report templates provided by Polyspace, the change does not impact you. If
you use MATLAB Report Generator™ to modify the Polyspace report templates, you can
open the templates from this new location.

Changes in Polyspace User Interface

The following table lists minor changes to the user interface including new pane names
and new icons.

* Results List — Window showing list of results, previously called Results
Summary.

@ — Button to remove items in the configuration or projects.

* The icons on the Results List pane have been rearranged.

In R20164a, the icons were arranged as follows.
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E Results Surmmary

[E | Al results v TxlNew <@ 5> (@ Showing 368/368

In R2016b, the same icons are arranged as follows.

E Results List
All results ~ Ik MNew =]+ <7 5> (@& Showing 368/368 +

1-28



R2016a

Version: 9.5
New Features
Bug Fixes

Compatibility Considerations



R2016a

Verification Setup

2-2

Files to Review: Generate results for only specified files and folders

In R2016a, you have greater control over the files on which you want analysis results.
The default project configuration displays coding rule violations and code metrics on the
set of files that are likely to be most relevant to you. You can add files or folders to this
set based on your requirements.

For instance, by default, coding rule violations and code metrics are generated on header
files that are located in the same folder as the source files. Often, other header files
belong to a third-party library. Though these header files are required for a precise
analysis, you are not interested in reviewing findings in those headers. Therefore, by
default, results are not generated for those headers. If you are interested in certain
headers from third-party libraries, you can add those headers to the subset on which
results are generated.

For more information, see:

+  Generate results for sources and (-generate-results-for)

* Do not generate results for (-do-not-generate-results-for)

Compatibility Considerations

In R20164a, by default, coding rule violations and code metrics are not generated for
headers unless they are in the same location as source files. Previously, if you ran
verification at the command line, by default, results were generated for all headers.

Due to the change in default behavior, if you rerun verification on a pre-R2016a project
without changing the options, you can lose review comments on findings in some header
files. To avoid losing the comments, set the option Generate results for sources and (-
generate-results-for) to al I-headers.

Faster MISRA Rule Checking: Check coding rules more quickly and
efficiently

In R20164a, you can use two predefined subsets to perform a quicker and more efficient
check for coding rule violations. The new subsets turn on rules that have the same scope.

+ single-unit-rules — Check rules that apply only to single translation units.


http://www.mathworks.com/help/releases/R2016a/codeprover/ref/generateresultsforsourcesandgenerateresultsfor.html
http://www.mathworks.com/help/releases/R2016a/codeprover/ref/donotgenerateresultsfordonotgenerateresultsfor.html
http://www.mathworks.com/help/releases/R2016a/codeprover/ref/generateresultsforsourcesandgenerateresultsfor.html
http://www.mathworks.com/help/releases/R2016a/codeprover/ref/generateresultsforsourcesandgenerateresultsfor.html
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+ system-decidable-rules — Check rules in the single-unit-rules subset
and some rules that apply to the collective set of program files. The additional rules
can be checked only at the integration level because the rules involve more than one
translation unit.

Polyspace finds these subsets of rules in the early phases of the analysis. If your project
is large, before checking all rules, you can check these subsets of rules for a preliminary
analysis.

For more information, see Coding Rule Subsets Checked Early in Analysis.

S-Function Analysis: Launch analysis of S-Function code from Simulink

With the Polyspace plug-in for Simulink, you can now start a Polyspace verification on S-
Functions directly from an S-Function block.

To analyze an S-Function, right-click the S-Function block and select Polyspace >
Verify S-Function. If the S-Function occurs in your model multiple times, you can
choose to analyze all instances of the S-Function by verifying all signal range inputs, or
just a single instance of the S-Function by verifying the specific signal ranges for that
block.

Polyspace Metrics Tomcat Upgrade: Use upgraded default Tomcat server
or custom Tomcat version

Polyspace Metrics now uses Tomcat 8.0.22 to run the Polyspace Metrics web interface.

If you want to use your own version of Tomcat, you can now specify a custom Tomcat
server in the daemon configuration file. To add your custom tomcat web server, add the
following line to the daemon configuration file.

tomcat_install_dir = <path/to/tomcat>
The daemon configuration file is located in:

* Windows — \%APPDATA%\Polyspace_RLDatas\polyspace.conf
* Linux — /Zetc/Polyspace/polyspace.conf

Project Language Flexibility: Change your project language at any time

Projects in the Polyspace interface are no longer fixed to C or to C++. When you create
a project, you can add any file to the project. After you add files, select the language for
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your analysis using the Source code language (-lang) option. If you add or change the files
in your project, you can change the language to reflect the most suitable analysis type.

Many options that were C only or C++ only are now available for both languages. To see
which analysis options have changed, see “Changes in analysis options” on page 2-9.

External Constraint on Pointers: Specify certain initialization with full
range for pointer arguments and return values of stubbed functions

In R20164, if a stubbed function in your code has a pointer argument or a return
value, you can specify certain constraints on the pointer outside your code. Using the
constraints, you can reduce the number of Non-initialized local variable checks. A
function is stubbed if you do not provide the function definition or if you specify the
function name for the option Functions to stub (-functions-to-stub). For instance, if you
declare a function Ffunc and do not provide the function definition, func is stubbed.

int* func (int* ptr);

You can specify the new external constraints for the pointer argument and the pointer
return value of func.

You can specify one of the following:

* The pointer points to a non-array variable and the variable is initialized.

The Init Allocated column in the constraint specification file supports a new entry
SINGLE_CERTAIN_WRITE that allows you to specify this constraint.

* The pointer points to an array and all elements of the array are initialized.

The Init Allocated column in the constraint specification file supports a new entry
MULTI_CERTAIN_WRITE that allows you to specify this constraint.

The following table illustrates the change.

Prior to R2016a R2016a
Without constraints, Polyspace assumes If you specify the following constraints
that x in bar and and bar_array are in the Init Allocated column, Polyspace

potentially noninitialized when you read considers that X in bar and bar_array are
them. You cannot specify that the functions |initialized.
foo and foo_array initialize X with full-

range values.



http://www.mathworks.com/help/releases/R2016a/codeprover/ref/sourcecodelanguagelang.html
http://www.mathworks.com/help/releases/R2016a/codeprover/ref/noninitializedlocalvariable.html
http://www.mathworks.com/help/releases/R2016a/codeprover/ref/functionstostubfunctionstostub.html

Verification Setup

Prior to R2016a

R2016a

#define SIZE 5
void foo(int *ptr);

int bar (void) {
int x;
foo(&x);
return Xx;

}

void foo_array(int *ptr);
void display(int val);

void bar_array(void) {
int xX[SI1ZE],sum=0;
foo_array(x);
for(int i=0; I<SIZE;
display(x[il);

i++)

+ foo: Specify SINGLE_CERTAIN_WRITE
for the argument of foo. In other words,
foo writes a value to *ptr.

+ Ffoo_array: Specify
MULTI_CERTAIN_WRITE for the
argument of foo_array. In other
words, ptr points to an array and
foo_array writes a value to the array
elements.

#define SIZE 5
void foo(int *ptr);

int bar (void) {
int x;
foo(&x);
return x;

}

void foo_array(int *ptr);
void display(int val);

void bar_array(void) {
int xX[S1ZE],sum=0;
foo_array(x);
for(int i=0; I<SIZE; i++)
display(xLiD):

For more information, see Constraints.

If your project uses a constraint specification file from a previous release, you do not see
any change in the verification results. If you generate a constraint specification file, by
default, pointer arguments of stubbed functions are constrained to point to an array that
is initialized. Applying the default constraint specification file can reduce the number of
orange Non-initialized local variable checks.
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Source Code Search: Search large applications more quickly

In R2016a, search results are produced more quickly. If you search for a string in a large
application, it takes less time for search results to appear.

You can search for a string either by entering the search string in the box on the Search
pane, or by right-clicking a word in your code on the Source pane, and then selecting a
search option.

Polyspace TargetlLink plug-in supports data from structures

The Polyspace plug-in for TargetLink® can now import data from structures in the
constraint specifications (formerly called DRS) for your analysis.

Polyspace Eclipse plug-in results location moved

When you analyze projects using the Polyspace plug-in for Eclipse, your results used to
be stored inside your Eclipse project under eclipse project folder\polyspace.
For new Eclipse projects, Polyspace now stores results in the Polyspace Workspace
under Polyspace Workspace\EclipseProjects\Eclipse Project Name, where
Polyspace Workspace is the default project location specified in your Polyspace
Interface preferences. For more information, see Results Location.

Improvements in automatic project creation from build command

In R2016a, automatic project creation from build command is improved.

+ If you trace your build command and create a Polyspace project from the command
line, you do not have to specify a product name or project language. You can open the
project in Polyspace Bug Finder™ or Polyspace Code Prover. The project language is
determined by using the following rules:

+ If all your files are compiled as C, as C++03, or C++11, the corresponding language
1s assigned to the project.

Language Options Set in Project

C Source code language: C
C++03 Source code language: CPP
C++11 Source code language: CPP
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Language

Options Set in Project

C++11 Extensions: On

+ If some files are compiled as C and the remaining files as C++03 or C++11, the
Source code language option is set to cpp.

The option C++11 Extensions is also enabled.

For more information, see Source code language (-lang) and C++11 Extensions (-

cppll-extensions).

Previously, you specified the product name by using options ~bug-finder or -code-
prover. If you did not specify a project language and your source code consisted of
both .c and .cpp files, the language cpp was assigned to the project. The options -
bug-finder and —code-prover have been removed.

For more information, see Create Project Automatically.

+ If header files in your project contain constructs that are not supported in Polyspace
Code Prover, a compilation error occurs. In R2016a, when you trace your build,
Polyspace detects such header files and does not add them to your project. Later,
when you run verification on the project, you do not face compilation errors because of
unsupported constructs in header files.

* The support for IAR compilers has improved. All variations of IAR compilers are now
supported for automatic project creation from build command.

Improvements in checking of previously supported MISRA C rules

In R20164a, the following changes have been made in checking of previously supported

MISRA C rules.
MISRA C:2004 Rules

Rule

Description

Improvement

MISRA C:2004 Rule
10.3

The value of a complex
expression of integer
type may only be

cast to a type that is
narrower and of the
same signedness as

The rule checker no longer raises a
violation of this rule if an expression
with a Boolean result is cast to a type
that is also effectively Boolean.

For instance, in your code, you define
a type myBool using a typedef
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Rule

Description

Improvement

the underlying type of
the expression.

and cast the result of (a && b) to
myBool. If you specify to Polyspace
that myBool is effectively Boolean,
the rule checker does not consider
this cast as a violation of rule 10.3.
For more information on how to
specify effectively Boolean types, see
Effective boolean types (-boolean-

types).

MISRA C:2004 Rule
12.2

The value of an
expression shall be the
same under any order
of evaluation that the
standard permits.

The rule checker no longer flags
expressions with the comma operator
that can be evaluated in only one
order.

For instance, the statement ans =
(val++, val++) does not violate
this rule.

MISRA C:2012 Rules

Rule Description Improvement

MISRA C:2012 Rule The value of an The rule checker no longer flags

13.2 expression and its expressions with the comma operator

persistent side effects
shall be the same
under all permitted
evaluation orders.

that can be evaluated in only one
order.

For instance, the statement ans =
(val++, val++) does not violate
this rule.

Variables with constraints not counted as orange sources

In R2016a, once you constrain certain variables outside your code, those variables do not
appear as possible causes of orange checks on the Orange Sources pane.

This pane lists the variables that you can constrain outside your code to reduce orange

checks.
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*  Previously, the pane listed variables even after you had constrained them, with the
assumption that you might constrain them further.

+ Starting in R2016a, Polyspace assumes that once you constrain variables to match
real-world values, you will not constrain them further.

Therefore, variables already constrained are not shown on the Orange Sources pane.

For more information on constraining variables using the Orange Sources pane, see
Create Constraint Template After Analysis.

Changes in analysis options
In R20164a, the following options have been added, changed, or removed.

New Options

Option Description

Generate results for sources and |Specify files on which you want analysis results.
(-generate-results-for)

Do not generate results for (-do- | Specify files on which you do not want analysis

not-generate-results-for) results.
Allow non finite floats (-allow- Enable a verification mode that incorporates
non-finite-floats) infinities and NaNs.
Float rounding mode (-float- Assume all rounding modes and extended precision
rounding-mode) when determining the results of floating point
arithmetic.
-check-infinite Specify how to handle floating point operations that
result in infinity.
-check-nan Specify how to handle floating point operations that
result in NaN.
-no-assumption-on-absolute- Make Absolute address usage checks orange by
addresses default.
Updated Options
Option Change More
Information
Source code language (-lang) Added to Polyspace Interface Select your
project
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Option

Change

More
Information

language to set
compilation
rules and
enable
language
specific
analysis
options.

Dialect (-dialect)

Unified dialects for C and C++
projects. All projects can use any
dialect option.

Target processor type (-target)

Targets 1386 and x86_64 now allow

any alignment value.

Sfr type support (-sfr-types)

Allowed for both C and C++

Pack alignment value (-pack-
alignment-value)

Allowed for both C and C++

Import folder (-import-dir)

Allowed for both C and C++

Ignore pragma pack directives (-
ignore-pragma-pack)

Allowed for both C and C++

Division round down (-div-
round-down)

Allowed for both C and C++

Removed Options

Option Status More Information

Green absolute address Warning |Absolute address usage checks are green

checks (-green-absolute- by default. To remove this assumption

address-checks) and produce an orange check, use the
option -no-assumption-on-absolute-
addresses.

Files and folders to ignore (- |Warning |Use the option Do not generate results

includes-to-ignore) for (-do-not-generate-results-for) to
suppress results from headers and
sources in certain files or folders.
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Option Status More Information

Ignore float rounding (- Warning |Option will be removed in a future

ignore-float-rounding) release.

-retype-pointer Warning |Option will be removed in a future
release.

-retype-int-pointer Warning |Option will be removed in a future
release.

—-lwtm Warning |Option will be removed in a future
release.

-support-FX-option-results|Warning |Option will be removed in a future
release.

polyspace-vcproj Error Binary has been removed.

Compatibility Considerations

If you use scripts that contain the removed or updated options, change your scripts
accordingly.
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Floating-Point Support: Propagate ranges more precisely for 1ong
double variables and enable verification mode to incorporate infinities
and NaNs

In R20164a, there are the following improvements on analysis of code involving floating-
point variables.

Long Doubles

If your code contains computations involving long double variables, you can see fewer
orange checks resulting from overapproximation. Previously, Polyspace assumed full-
range value for long double variables, irrespective of the actual values assigned to
them. This assumption led to orange checks that indicated potential numerical and other
errors in computations involving long double variables.

Polyspace now propagates ranges more precisely for long double variables. For
information on the number of bits that Polyspace uses for computations involving long
double variables, see Target processor type (-target).

Nonfinites in floating-point arithmetic

Polyspace verification supports nonfinite results such as infinities and NaNs from
computations involving floating-point variables. Using the option Allow non finite floats
(-allow-non-finite-floats), you can enable a verification mode that incorporates infinities
and NaNs.

In this mode, Polyspace assumes that:
* Floating-point operations can produce results such as infinities and NaNs.

Using options -check-infinite and -check-nan, you can choose to highlight operations
that produce nonfinite results and stop the execution paths where the nonfinite
results occur.

* Floating-point variables with unknown values, such as volati le variables and
return values of stubbed functions, can be infinite or NaN.

The following table illustrates the change.
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Prior to R2016a

R2016a

In the following code, Polyspace produces
a Division by zero error and stops
verification.

double func(void) {
double x=1.0/0.0;
double y=1.0/x;
double z=x-Xx;
return z;

In the following code, if you specify the
option Allow non finite floats, Polyspace
does not check for a Division by zero
error.

double func(void) {
double x=1.0/0.0;
double y=1.0/x;
double z=x-x;
return z;

}

The verification assumes that dividing by
zero results in:

+ Value of X equal to Inf

+ Value of y equal to 0.0

+ Value of z equal to NaN

In your verification results in the Polyspace
user interface, if you place your cursor on y

and z, you can see the nonfinite values Inf
and NaN respectively in the tooltip.

Rounding modes

Polyspace supports verification that considers all possible rounding modes and extended
precision when rounding the results of floating point arithmetic. Using the option Float
rounding mode (-float-rounding-mode), you can enable a verification mode with the

following assumptions:

* These rounding modes are possible: round-to-nearest, round-towards-zero, round-
towards-positive-infinity and round-towards-negative-infinity.

The default assumption is round-to-nearest only.

+  Extended precision can be used for rounding.

The default assumption emulates the GCC flag -ffloat-store and disallows

extended precision.
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Previously, the default verification assumed all rounding modes and extended precision
to determine the results of floating-point arithmetic. The verification used the round-to-
nearest mode without extended precision only to determine if an Overflow occurs.

The following table illustrates the change.

Prior to R2016a

R2016a

In the following code, Polyspace produces
a green Overflow check because the
addition does not overflow if the result is
rounded in to-nearest mode.

#include <float.h>

void func(void) {

double base = DBL_MAX;

double acc = 1.247400193459199882
285232945648024103792
1570377722e+291;

base = acc + base;

In the following code, if you specify all

for the option Float rounding mode,
Polyspace produces an orange Overflow
check because the addition overflows if the
result is rounded towards positive infinity.

#include <float.h>

void func(void) {

double base = DBL_MAX;

double acc = 1.247400193459199882
285232945648024103792
1570377722e+291 ;

base = acc + base;

Absolute address usage valid by default

In R20164a, the Absolute address usage check is considered valid and therefore green
by default. If you assign an absolute address to a pointer in your code, the verification

assumes that:

* The address 1s valid.

* The type of the pointer to which you assign the address determines the initial value

stored in the address.

If you assign the address to an Int* pointer, the memory zone that the address points
to is initialized with an Int value. The value can be anything that is allowed for the

data type int.

Previously, the Absolute address usage check was considered possibly invalid and
therefore orange by default. You either justified the checks or turned them green by
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using the option Green absolute address checks (-green-absolute-address-
checks on command line).

Compatibility Considerations

If the code in your project uses absolute addresses, you see a decrease in the number
of orange checks from previous releases of the software. To turn the check orange by
default for each absolute address usage, use the command-line option -no-assumption-on-

absolute-addresses. To use a command-line option in the user interface, enter the option
in the Other field.

Run-time checks renamed

In R2016a, the following checks have been renamed. The new names state the error in
the code instead of what the check looks for.

Old Name New Name

Absolute address Absolute address usage

C++ specific checks Invalid C++ specific operations
Exception handling Uncaught exception

Function Returns a Value Function not returning value
Initialized Return Value Return value not initialized
Non-null this-pointer in Null this-pointer calling method
method

Object Oriented Incorrect object oriented programming
Programming

Shift operations Invalid shift operations
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Autocompletion for Review Comments: Partially type previous comment
to select complete comment

In R20164a, on the Results Summary or Result Details pane, if you start typing a
review comment that you have previously entered, a drop-down list shows the previous
entry. Select the previous comment from this list instead of retyping the comment.

If you want the autocompletion to be case sensitive, select Tools > Preferences. On the
Miscellaneous tab, select Autocomplete on Results Summary or Details is case
sensitive.

Default Layouts: Switch easily between project setup and results review in
user interface

In R20164a, you have two default layouts of panes in the Polyspace user interface, one for
project setup and another for results review.

When setting up your projects, select Window > Reset Layout > Project Setup. When
reviewing results, select Window > Reset Layout > Results Review.

For more information, see Organize Layout of Polyspace User Interface.

Persistent Filter States: Apply filters once and view filtered results across
multiple runs

In R20164, if you apply a set of filters to your verification results and rerun verification
on the project module, your filters are also applied to the new results. You can specify

your filters once and suppress results that are not relevant for you across multiple runs.

The Results Summary pane shows the number of results filtered from the display. If
you place your cursor on this number, you can see the applied filters.
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Showing 187/365

Showing 187 out of 365 possible results
Hidden results: 178

Review Scope: Checks & Rules

Mew results only: On

Columns with active filters:

Information
Check

For instance, in the image, you can see that the following filters have been applied:
+ The Checks & Rules filter to suppress code metrics and global variables.

° B ] . . . . e .
The filter to suppress results found in a previous verification.

+ Filters on the Information and Check columns.

For more information, see Filter and Group Results.

Updated Polyspace Metrics Interface: View summary of project and
metrics

You can now view project-level metric summaries from the main Polyspace Metrics page
using one of the following methods:

+  On the Projects tab, roll your mouse over the list of projects to open a window
displaying a summary of the project and project metrics.

*  On the Projects or Runs tab, right-click the column headers to add new columns to
the table. new columns you can add include Coding Rules, Bug-Finder Checks, Code
Metrics, and Review Progress.

Improved Result Display for File-by-File Verification: View combined
summary of results for all files in user interface

In R20164a, if you perform a file-by-file verification, you can see a summary of results for

all files on the Dashboard pane. You can open the results for each file directly from this
summary table. Previously, you obtained this synthesis in an external html file.
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For more information, see Run File-by-File Local Verification.

Simplified Variable Access: View task names instead of aliases

In R20164a, on the Variable Access pane, in the Written by task and Read by task
columns, you see the task names. Previously, the columns contained aliases such as t1,
t2, t3, ... You viewed the task names using a legend for the aliases.
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Option to Suppress Non-initialization Checks: Customize verification by
suppressing non-initialization checks

In R2015b, you can use an analysis option to turn off the checks for non-initialization. If
you turn on this option, Polyspace assumes that, at declaration:

+ Variables have full-range of values allowed by their type.

+  Pointers can be NULL-valued or point to a memory block at an unknown offset.
When you use this option, the following checks are turned off:

+  Non-initialized local variable: Local variable is not initialized before being read.

* Non-initialized variable: Variable other than local variable is not initialized before
being read.

* Non-initialized pointer: Pointer is not initialized before being read.

*  Return value not initialized: C function does not return value when expected.

For more information, see Disable checks for non-initialization (C/C++).

Autodetection of Multitasking Primitives: Analyze source code with
multitasking primitives from POSIX or VxWorks without manual setup

If you use POSIX®™ or VxWorks to perform multitasking, Polyspace can now interpret
your multitasking code without having to change your code or manually set multiple
configuration options.

To turn on automatic detection, select the analysis option Multitasking > Enable
automatic concurrency detection. Polyspace detects thread creation and critical
sections from supported multitasking functions.

Functions Polyspace can interpret:
POSIX

* pthread_create
* pthread_mutex_lock
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* pthread_mutex_unlock

VxWorks

+ taskSpawn
+ semTake
+ semGive

For more information, see Enable automatic concurrency detection (C/C++).

Microsoft Visual C++ 2013 Support: Analyze code developed in Microsoft
Visual C++ 2013

You can analyze code developed in the Microsoft® Visual C++* 2013 dialect.

To analyze code compiled with Microsoft Visual C++ 2013, set your dialect to
visuall12.0. If you specify the dialect, Polyspace allows language extensions specific to
Microsoft Visual C++ 2013. Otherwise, it produces a compilation error if you use those
extensions. For more information, see Dialect (C/C++) or Dialect (C++).

GNU 4.9 and Clang 3.5 Support: Analyze code compiled with GCC 4.9
or Clang 3.5

Polyspace now supports the GNU 4.9 and Clang 3.5 dialects for C and C++ projects.

To analyze code compiled with one of these dialects, set the Target & Compiler >
Dialect option to gnu4.9 or clang3.5.

For more information, see Dialect (C/C++) or Dialect (C++).

Improvements in automatic project creation from build command
In R2015b, automatic project creation from build command is improved.

+ If you build your source code from the Cygwin™ environment (using either a 32 or
64-bit installation), Polyspace can trace your build and create a Polyspace project or
options file.

*  Support for the following compilers has improved:

3-3


http://www.mathworks.com/help/releases/R2015b/codeprover/ref/enable-automatic-concurrency-detection.html
http://www.mathworks.com/help/releases/R2015b/codeprover/ref/dialect.html
http://www.mathworks.com/help/releases/R2015b/codeprover/ref/dialect-1.html
http://www.mathworks.com/help/releases/R2015b/codeprover/ref/dialect.html
http://www.mathworks.com/help/releases/R2015b/codeprover/ref/dialect-1.html

R2015b

+ Texas Instruments™ C2000 compiler

This compiler is available with Code Composer Studio™.
+ Cosmic HC08 C compiler
+ MPLAB XC8 C Compiler
With certain compilers, the speed of tracing your build command has improved.

The software now stores build information in the system temporary folder, thereby
allowing faster access during the build.

If you still encounter a slow build, use the advanced option —-cache-path ./
ps_cache when tracing your build. For more information, see Slow Build Process
When Polyspace Traces the Build.

If the software detects target settings that correspond to a standard processor type, it
assigns that standard target processor type to your project. The target processor type
defines the size of fundamental data types and the endianness of the target machine.
For more information, see Target processor type (C/C++).

Previously, when you created a project from your build command, the

software assigned a custom target processor type. Although you saw

the processor type in the form of an option such as —~custom-target
true,8,2,4,-1,4,8,4,8,8,4,8,1,little,unsigned_int, int,unsigned_short,
you could not identify easily how many bits were associated with each fundamental
type. With this enhancement, when the software assigns a processor type, you can
identify the number of bits for each type. Click the Edit button for the option Target
processor type.

Automatic project creation uses a configuration file written for specific compilers. If
your compiler is not supported, you can adapt one of the existing configuration files
for your compiler. The configuration file, written in XML, is now simplified with some
new elements, macros and attributes.

+ The preprocess_options_list element supports a new $(OUTPUT_FILE)
macro when the compiler does not allow sending the preprocessed file to the
standard output.

A new preprocessed_output_Tfile element allows the preprocessed file name
to be adapted from the source file name.

* The semantic_options element supports a new isPrefix attribute. This
attribute provides a shortcut to specify multiple semantic options that begin with
the same prefix.
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+ The semantic_options element supports a new numArgs attribute. This
attribute provides a shortcut to specify semantic options that take one or more
arguments.

For more information, see Compiler Not Supported for Project Creation from Build
Systems.

*  Sometimes, the build command returns a non-zero status even when the command
succeeds. The non-zero status can result from warnings in the build process. However,
Polyspace does not trace the build and create a Polyspace project. You can now use
an option —al low-build-error to create a Polyspace project even if the build
command returns an exit status or error level different from zero. This option helps
you understand the error in the build process.

For more information, see —option value arguments of polyspaceConfigure.

Start Page: Get quickly familiar with Polyspace Code Prover

In R2015b, when you open Polyspace Code Prover for the first time, a Start Page pane
appears. From this pane, you can:

*  Open recent results and demo examples.

* Start a new project.

* Get additional help using the Getting Started, What’s New and Learn More tabs.

If you select the Show on startup box on the lower left of this pane, the pane appears
each time you open Polyspace Code Prover. Otherwise, if you close the pane once, it does
not reopen. To open the pane, select Window > Show/Hide View > Start Page.

Saved Layouts: Save your preferred layouts of the Polyspace user
interface

In R2015b, if you reorganize the Polyspace user interface and place the various panes in
more convenient locations, you can save your new layout. If you change your layout, you
can quickly revert to a saved layout.

With this modification, you can create customized layouts suitable for different
requirements and switch between saved layouts. For instance:

* You can have separate layouts for project configuration and results review.
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* You can have a minimal layout with only frequently used panes.

For more information, see Organize Layout of Polyspace User Interface.

Renaming of labels in Polyspace user interface

In the Polyspace user interface, the following labels have been renamed:

*  On the Configuration pane, the node Coding Rules is changed to Coding Rules
& Code Metrics. The Coding Rules & Code Metrics node contains the option
Calculate Code Metrics, which appeared previously on the Advanced Settings
node.

*  On the Results Summary pane, the Category column title is changed to Group,
avoiding confusion with coding rule categories.

*  On the Results Summary and Result Details pane, the field Classification is
changed to Severity. You assign a Severity such as High, Medium and Low to a
defect to indicate how critical you consider the issue.

+ The labels associated with specifying constraints have changed as follows:

*  On the Configuration pane, the field Variable/function range setup is
changed to Constraint setup.

* When you click Edit beside the Constraint setup field, a new window opens. The
window name is changed from Polyspace DRS Configuration to Constraint
Specification.

For more information, see Specify Constraints.

Including options multiple times

You can now specify analysis options multiple times. This feature is available only at
the command line or using the command-line names in the Advanced options dialog
box in the user interface. Customize pre-made configurations without having to find the
changed options in the options file.

If you specify an option multiple times, only the last setting is used. For example, if your
configuration is:

-lang c
-prog test_bf _cp
-verif-version 1.0
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-author username

-sources-list-file sources.txt

-0S-target no-predefined-0S

-target 1386

-dialect none

-misra-cpp required-rules

-target powerpc

Polyspace uses the last target setting, powerpc, and ignores the other target specified,
1386.

The user interface also follows this rule. If you specify ¢18 for Target processor type
and -target 1386 for Advanced options, this counts as multiple analysis option
specifications. Polyspace uses the target specified in the Advanced options box, 1386.

Compatibility Considerations

If your current configuration specifies analysis options multiple times, change the
configuration by either:

*  Removing the unnecessary analysis options.

* Moving the desired analysis options to the end of the configuration.

Updated Support for Targetlink

The Polyspace plug-in for TargetLink now supports versions 3.5 and 4.0 of the dSPACE®
Data Dictionary and TargetLink Code Generator.

dSPACE and TargetLink version 3.4 is no longer supported.

For more information, see TargetLink Considerations.

Improved handling of __declspec

For projects in Visual C, Polyspace Code Prover can now interpret the aligned size
specified by the keyword __declspec( align( .. ) .. ).

For example, this structure uses the __declspec keyword:

struct S1 { _ declspec(align(8)) char c; };
In R2015b Polyspace correctly interprets the size of S1 as 8 bytes.
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Compatibility Considerations

In previous versions, Polyspace ignored the _declspec keyword, so code with the
__declspec(align() ) keyword was verifiable using Dialect > None. To avoid
compilation errors with the R2015b support of __declspec(align() ), set Dialect to
one of the Visual C dialects. For the list of supported Visual dialects, see Dialect (C/C++).

Changes in analysis options

In R2015b, the following options have been added or removed.

New Options

Option Status More information

Respect C90 Standard New The analysis does not allow C language
extensions that do not follow the ISO/TEC

(-no-language- 9899:1990 standard.

extensions)

Dialect visual12.0 New Allows Microsoft Visual C++ 2013 (visual
12) language extensions.

Dialect gnu4.9 New Allows GCC 4.9 language extensions.

Dialect clang3.5 New Allows Clang 3.5 language extensions.

Configure multitasking New This option enables the previous

manually (C/C++) multitasking options (Entry points,
Critical section details, Temporally
exclusive tasks) in the user interface.

Enable automatic New Enables automatic concurrency detection

concurrency detection (C/C+
+)

for POSIX® and VxWorks® threading
functions.

Disable checks for non- New Disables checks for non-initialization in
initialization (C/C++) your code.

Updated Options

Option Status More information

Calculate Code Metrics (C/C

++)

Moved in user
interface

The option has been moved in the
Configuration panel from the Advanced
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Option

Status

More information

Settings pane to the Coding Rules and

Code Metrics pane.

-class-analyzer

Updated syntax

The syntax for ~-class-analyzer
param has been updated. Use -class-
analyzer custom=param

Signed right shift (C/C++)

(-logical-signed-
right-shift)

Now available
in C++ projects

Division round down (C/C+
+)

(-div-round-down)

Now available
in C++ projects

(-no-def-init-glob)

Now available
in C++ projects

Optimize large static
initializers (C/C++)

(-no-fold)

Now available
in C++ projects

-lightweight-thread-
model

No longer
available in the
user interface

Targets:

+ tms320c3x
+ ,sharc21x61

Now available
in C++ projects

necv850
+ hc08
+ hci12
mpCcSxx
- 18
Enum type definition (C/C+ |Possible values |The possible values for ~enum-type-

+)

updated

definition are the same for C and C++.

Available values:
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Option Status More information
(-enum-type- defined-by-standard (default)
definition)

+ auto-signed-first
+ auto-unsigned-first

-asm-begin -asm-end

Now available
in C++ projects

-support-FX-option-
results

No longer
available in the
user interface

-pointer-is-24bits

Available in C+
+ projects

Availably only if you use the Target
setting c18.

Output format (C/C++)

Possible values

The output format RTF is deprecated

updated and not available on the Configuration
-report-output-format pane.
Removed Options
Option Status More information
-dialect cfront2 Removed |Use a different dialect instead.
-dialect cfront3 Removed | Use a different dialect instead.
-known-NTC Removed | Polyspace includes this behavior by
default. Remove this option from existing
configurations.
-desktop Removed |Use -main-generator instead.
-permissive Removed |Use -allow-negative-operand-in-shift
-ignore-constant-overflows instead.
—automatic-stubbing Removed | Polyspace includes this behavior by
default. Remove this option from existing
configurations.
-float-overflows Removed | Polyspace includes this behavior by

default. Remove this option from existing
configurations.
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Option Status More information

-continue-with- Removed | Polyspace includes this behavior by

exisiting-host default. Remove this option from existing
configurations.

-allow-unsupported- Removed | Polyspace includes this behavior by

linux default. Remove this option from existing
configurations.

-passes-time Removed | Polyspace includes this behavior by
default. Remove this option from existing
configurations.

—-ignore-missing- Removed |Polyspace includes this behavior by

headers default. Remove this option from existing
configurations.

-continue-with-red- Removed | Polyspace includes this behavior by

error default. Remove this option from existing
configurations.

-voa Removed | Polyspace includes this behavior by
default. Remove this option from existing
configurations.

-machine-architecture |Removed |Polyspace includes this behavior by
default. Remove this option from existing
configurations.

-allow-non-int- Removed | Polyspace includes this behavior by

bitfield default. Remove this option from existing
configurations.

-allow-undef- Removed | Polyspace includes this behavior by

variables default. Remove this option from existing
configurations.

-allow-unnamed-fields |Removed  Polyspace includes this behavior by
default. Remove this option from existing
configurations.

-permissive stubber Removed | Polyspace includes this behavior by

default. Remove this option from existing
configurations.

3-11



R2015b

Option Status More information

-permissive-link Removed | Polyspace includes this behavior by
default. Remove this option from existing
configurations.

-allow-language- Removed | Polyspace includes this behavior by

extensions default. Remove this option from existing
configurations.

-include-headers-once |Removed |Polyspace includes this behavior by
default. Remove this option from existing

configurations.
-strict Removed |This option is no longer supported. Remove
this option from existing configurations.
-discard-asm Removed |This option is no longer supported. Remove
this option from existing configurations.
-quick Removed Use -to passO instead.
-detect-unsigned- Removed |Use -scalar-overflows-checks-signed-
overflows and-unsigned instead.
-misra2 AC-AGC-OBL- Removed |Use -misra-ac-agc OBL-rules instead.
subset

Compatibility Considerations

If you use scripts that contain a removed or updated option, change your scripts
accordingly.

Binaries removed

The following binaries have been removed.

Binary name Use instead

polyspace-automatic -orange- From the Polyspace environment, select Tools >

tester.exe Automatic Orange Tester

polyspace-c.exe polyspace-code-prover-nodesktop -lang c

polyspace-cpp.exe polyspace-code-prover-nodesktop -lang
cpp
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Binary name

Use instead

polyspace-remote-c.exe

polyspace-code-prover-nodesktop -lang c
-batch

polyspace-remote-cpp.exe

polyspace-code-prover-nodesktop -lang
cpp -batch

polyspace-remote.exe

polyspace-code-prover-nodesktop -batch

polyspace-rlI-manager.exe

polyspace-server-settings.exe

polyspace-spooler.exe

polyspace-job-monitor.exe

polyspace-ver.exe

polyspace-code-prover-nodesktop -ver

The binaries to use are located in matlabroot/polyspace/bin.

Support for Visual Studio 2008 to be removed

The Polyspace Add-In for Visual Studio 2008 is no longer supported and will be removed

in a future release.

Compatibility Considerations

To analyze your Visual Studio projects, use either:

* The Polyspace Add-in for Visual Studio 2010. See Install Polyspace Add-In for Visual

Studio.

+ The polyspace-configure tool to create a project using your build command. See
Create Project Using Visual Studio Information.

Import Visual Studio project removed

The Tools > Import Visual Studio project has been removed.

To import your project information from Visual Studio, use the Create from build
system option during new project creation. For more information, see Create Project

Using Visual Studio Information.
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Improved Concurrency Detection: View more precise sharing and
protection results based on dynamic information such as data flow in
branching statements and protection on individual fields of a structure

In R2015b, Polyspace Code Prover uses dynamic information such as data flow in branch
statements to determine whether a variable is shared and protected. Previously, sharing
and protection were determined statically resulting in overapproximation of the actual
behavior. For more information on shared variables and multitasking options, see

Multitasking.

The following examples illustrate the change. For more examples, see Global Variables.

Data Flow in Branch Statements

Prior to R2015b

R2015b

In the following code, if you specify taskl
and task?2 as entry points, the verification
determines that var_1 and var_2 are
shared, potentially unprotected variables.
However, because of the 1 f statement,
taskl can operate only on var_1 and
task2 only on var_2. When determining
sharing, the verification does not consider
the branching in the i f statement and
therefore determines that var_1 and
var_2 are shared.

unsigned
unsigned
volatile

int var_1;
int var_2;
int randomVal;

void taskl(void) {
while(randomval)
operation(l);
}

void task2(void) {

In the following code, if you specify taskl

and task?2 as entry points, the verification
determines that var_1 and var_2 are not
shared.

unsigned int var_1;
unsigned int var_2;
volatile int randomVal;

void taskl(void) {
while(randomVal)
operation(l);
}

void task2(void) {
while(randomVal)
operation(2);

s
void operation(int i) {
if(i==1) {
var_1++;
b
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Prior to R2015b R2015b
while(randomval) else {
operation(2); var_2++;
} }
}
void operation(int 1) {
if(i==1) { int main(void) {
var_1++; return O;
} }
else {
var_2++;
}
}
int main(void) {
return O;
}
Shared Structures
Prior to R2015b R2015b

In the following code, if you specify taskl
and task?2 as entry points, the verification
determines that the structure variable
sharedStruct is a potentially unprotected
variable. However, taskl can operate only
on sharedStruct.var_1 and task2 only
on sharedStruct.var_2. The verification
considers sharedStruct as a whole and
ignores the sharing and protection on
individual fields of sharedStruct.

struct S {
unsigned int var_1;
unsigned int var_2;

};
volatile int randomval;
struct S sharedStruct;

void taskl(void) {

In the following code, if you specify taskl
and task?2 as entry points, the verification
determines that the structure variable
sharedStruct is a shared, protected
variable. If you select the result, the
Result Details pane states that all
operations on the variable are protected
by access pattern. For the variable
sharedStruct, the Protection column
on the Variable Access pane contains
Access pattern.

struct S {
unsigned int var_1;
unsigned int var_2;

};
volatile int randomVval;

struct S sharedStruct;
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void task2(void) {
while(randomval)
operation2();
}

void operationl(void) {
sharedStruct.var_1++;
}

void operation2(void) {
sharedStruct.var_2++;

}

int main(void) {
return O;

}

Prior to R2015b R2015b
while(randomval)
operationl(); void taskl(void) {
} while(randomVal)

operationl();
}

void task2(void) {
while(randomVal)
operation2();
}

void operationl(void) {
sharedStruct.var_1++;
}

void operation2(void) {
sharedStruct.var_2++;

}

int main(void) {
return O;

}

Additional MISRA C:2012 Support: Detect violations of all MISRA C:2012

rules except rules 22.x

In R2015b, Polyspace Code Prover supports the following MISRA C: 2012 coding rules.

For complete MISRA C: 2012 support, including rules 22.1-22.4 and 22.6, use Polyspace

Bug Finder.

Rule Description

MISRA C:2012 Directive 2.1 | All source files shall compile without any compilation

errors.

MISRA C:2012 Directive 4.5 |Identifiers in the same name space with overlapping

visibility should be typographically unambiguous.

MISRA C:2012 Rule 2.6

A function should not contain unused label declarations.

MISRA C:2012 Rule 2.7

There should be no unused parameters in functions.
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Rule

Description

MISRA C:2012 Rule 17.5

The function argument corresponding to a parameter
declared to have an array type shall have an appropriate
number of elements.

MISRA C:2012 Rule 17.8

A function parameter should not be modified.

MISRA C:2012 Rule 21.12

be used.

The exception handling features of <fenv.h> should not

MISRA C:2012 Rule 22.5

A pointer to a FILE object shall not be dereferenced.

Improved precision for mathematical functions

Polyspace Code Prover has more precise implementations for mathematical functions

defined in math.h.

Improvements in checking of previously supported MISRA C rules

In R2015b, the following changes have been made in checking of previously supported

MISRA C rules.

MISRA C:2004 Rules

Rule Description Improvement

MISRA C:2004 Rule |Assembly language If an assembly language statement
2.1 shall be encapsulated |is entirely encapsulated in macros,

and isolated.

Polyspace no longer considers that the
statement violates this rule.

MISRA C:2004 Rule
8.8

An external object
or function shall be
declared in one file
and only one file.

Polyspace considers that variables or
functions declared extern in a non-
header file violate this rule.

MISRA C:2004 Rule
10.1

The value of an
expression of integer
type shall not be
implicitly converted to
a different underlying
type if it is not a

Polyspace no longer raises violation
of this rule on operations involving
pointers.
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Rule

Description

Improvement

conversion to a wider
integer type of the
same signedness.

MISRA C:2004 Rule
19.2

Nonstandard
characters should not
occur in header file
names in #include
directives.

Polyspace no longer raises violation
of this rule if the character \ or \

\ occurs between the < and > in
#include <filename> (or between
"and " in #include "filename").

Therefore, you can use Windows
paths to files in place of Fi lename
without triggering a rule violation.

MISRA C:2012 Rules

Rule

Description

Improvement

MISRA C:2012 Directive
4.3

Assembly language
shall be encapsulated
and isolated.

If an assembly language statement

is entirely encapsulated in macros,
Polyspace no longer considers that the
statement violates this rule.

MISRA C:2012 Rule 1.1

The program shall
contain no violations of
the standard C syntax
and constraints, and
shall not exceed the
implementation's
translation limits.

If a rule violation occurs because your
-C file contains too many macros,
instead of placing the rule violation
on the last macro usage, Polyspace
places the rule violation at the
beginning of the file.

Therefore, you can add a comment
before the first line of the .c file
justifying the violation. Previously,
you had to place the comment before
the last macro usage. If you added
another use of the macro later,

the comment did not apply. For
information on adding code comments
to justify results, see Add Review
Comments to Code.
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Rule Description Improvement

MISRA C:2012 Rule Both operands of an + If one of the operands is the

10.4 operator in which constant zero, Polyspace does not
the usual arithmetic raise a violation of this rule.

conversions are
performed shall have
the same essential
type category.

If one of the operands is a signed
constant and the other operand

1s unsigned, the rule violation is
not raised if the signed constant
has the same representation as its
unsigned equivalent.

For instance, the statement u8b =
u8a + 3;, where u8a and u8b are
unsigned char variables, does
not violate the rule because the
constants 3 and 3U have the same
representation.

Checking Coding Rules Using Text Files

In R2015b, if your coding rules configuration text file has an incorrect syntax, the
analysis stops with an error message. The error message states the line numbers in the
configuration file that contain the incorrect syntax.

For more information on checking for coding rules using text files, see Select Specific
MISRA or JSF Coding Rules.

Change in Correctness Condition Check

In R2015b, the specification of the Correctness Condition check has changed in the
following way. For more information on the check, see Correctness condition.

When you use a function pointer to call a function and Polyspace cannot determine which
function the pointer points to, the Correctness Condition check is orange instead of
red. This situation can occur, for instance, if:

+ The function pointer points to an absolute address. The check is orange because the
verification cannot determine from the code whether the absolute address contains a
well-typed function.
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+ The function pointer contains the return value of a stubbed function. For information
on stubbing, see Assumptions About Stubbed Functions.

Following the orange check, the verification assumes that the following variables can
have the full range of values allowed by their type:

+ Variable storing the return value from the function call.

* Variables that can be modified through the function arguments.

Compatibility Considerations

If your code contains function pointers that point to an absolute address for instance,

you can see a change in the number of results from a previous version of the product.
Because red checks stop further verification of the code in the current block and orange
checks do not, this change of the Correctness Condition check from red to orange can
expose more of your code to verification. Therefore, the number of checks in your code can
change.
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Improved Review Capability: View result details and add review
comments in one window

In R2015b, the Check Details pane is renamed Result Details. On this pane, in
addition to viewing details about a result, you can now enter review information such
as Classification, Status, and comments. For more information, see Add Review
Comments to Results.

L EEEEEEEEEEEEEEEEE——————————==

;"3;1 04.3 H?_EI | _;5:: X single_file_analysis.c / reset_temperature()
[= Result Review

Classification .High | Jro perform checks for array index.

Status Fix v

! but of bounds array index

Error: array index is outside its bounds : [0..38]
array size: 39
array index value: [-255 .. -39]

Enhanced Review Scope: Filter coding rule violations from display in one

click

In R2015b, you can suppress a certain number or percentage of coding rule violations

from the display using custom options in the Show menu on the Results Summary
pane. You can:

+  Suppress violations of coding rules that are not relevant for you.

Focus your results review by seeing only a certain number of coding rule violations in
your display.

Predefine a percentage of coding rule violations that you intend to review. View only
that percentage in your analysis results.
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You define an option on the Show menu only once. The option is available for one-click
use every time that you open your results. For more information, see Suppress Certain
Rules from Display in One Click.

Previously, using custom options on the Show menu, you suppressed orange checks
and code metrics (if they fell below a certain threshold). With this enhancement, you
can use the Show menu to display only those results that must be justified to reach a
certain Software Quality Objective (SQO) level. For instance, you can reach predefined
SQO levels 4, 5, and 6 using the options on the Show menu. For more information, see
Software Quality Objectives.

Additional Call Graph Showing Task Creation

For global variables, the call graph provides a visual representation of the function call
sequence leading to operations on the variable. In R2015b, the call graph for shared
global variables has been augmented with a supporting call graph that shows task
creation.

Previously, Polyspace modeled multitasking code by assuming that all tasks begin after
the main completes execution. This model has been relaxed for POSIX thread creation
functions allowing creation of tasks in the main and in functions called from the main.
Therefore, the call sequence leading to the creation of a task can be nontrivial. The task
creation call graph provides you a visual representation of this call sequence.

For more information, see Review Global Variable Usage.

Improvements in Polyspace Metrics workflow

In R2015b, the Polyspace Metrics workflow has improved in the following ways:

* You can justify code complexity metrics in the Polyspace user interface and upload the
justifications to Polyspace Metrics. If a code metric value violates quality thresholds

and appears red, after justification, it appears green with the v icon.

For more information about justifying Polyspace results starting from the Polyspace
Metrics interface, see Compare Metrics Against Software Quality Objectives.

* You can define custom SQO levels specific to a project. In the file Custom-SQO-
Definitions.xml, if you specify a project name, in the Polyspace Metrics web
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dashboard, the custom SQO level appears only for that project. You can choose this
SQO level to compare the project against quality thresholds that you defined. For
more information, see Customize Software Quality Objectives.

In the Polyspace user interface, the same menu item Metrics > Upload to
Metrics allows you to upload your results initially and also upload comments and
justifications in the results later.

Previously, you used a different menu item Save comments to Metrics to save your
review comments and justifications in a result.

For more information on uploading comments and justifications from the Polyspace
user interface to the Polyspace Metrics web interface, see Review Metrics for
Particular Project or Run.

Improvements in Polyspace Plugin for Eclipse

In R2015b, the following improvements have been made to the Polyspace plugin for
Eclipse:

When you select a result in the Results Summary view, the Result Details view
displays additional information about the result. In the Result Details view, if

you click the “L/ button next to the result name, you can see a brief description and
examples of the result.

You can switch to a Polyspace perspective that shows only the information relevant to
a Polyspace Code Prover verification. To open the perspective, select Window > Open
Perspective > Other. In the Open Perspective dialog box, select Polyspace.

Improvements in Report Templates

In R2015b, the major improvements in report templates include the following:

Instead of filenames, absolute paths to files appear in the reports.

If you check for coding rules, the appendix about coding rules configuration states all
rules along with the information whether they were enabled or disabled. Previously,
the appendix only stated the enabled rules.

For more information on templates, see Report template (C/C++).
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Configuration Associated with Result Not Opened by Default

In R2015b, when you open your result, the Configuration pane does not automatically
display a read-only form of the associated configuration.

To view the configuration associated with the result, select the link View configuration
for results on the Dashboard pane. If a corresponding project is open on the Project
Browser pane, you can also right-click the result under the Results node in the project
and select Open Configuration.

XML and RTF report formats removed

The formats XML and RTF for report generation are no longer available from R2016a
onwards. If you generated reports using one of these formats, use an alternative format
instead.

For more information, see Output format (C/C++).
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Simplified workflow for project setup and results review with a unified
user interface

In R2015a, the Project and Results Manager perspectives are now unified. You can run
verification and review results without switching between two perspectives.

The major changes are:

* You can start a new verification during your results review. Previously, you started a
new verification only from the Project Manager perspective.

+ After a verification, the result opens automatically. If you are looking at a previous
result when a verification is over, you can load the new result or retain the previous
one on the Results Summary pane. If you retain the previous results, you can later
open the new results from the Project Browser. The new results are highlighted.

* You can have any of the panes open in the unified interface.

Previously, you could open the following panes only in one of the two perspectives.

Project Manager

Results Manager

4-2

Project Browser: Set up project.

Configuration: Specify analysis
options for your project.

Output Summary: Monitor progress
of verification.

Run Log: Find detailed information
about a verification.

Results Summary: View Polyspace
results.

Source: View read-only form of
source code color coded with Polyspace
results.

Check Details: View details of a
particular result.

Check Review: Comment on a
particular result.

Variable Access: View global
variables and read/write operations on
them.

Call Hierarchy: View callers and
callees of a function.

Results Properties: Same as Run
Log, but associated with results




Verification Setup

Project Manager

Results Manager

instead of a project. This pane has
been removed.

To open the log associated with a
result, with the results open, select
Window > Show/Hide View > Run
Log.

Settings: Same information as
Configuration, but associated with
results instead of a project. This pane
has been removed.

To open the configuration associated
with a result, with the results open,
select Window > Show/Hide View >
Configuration.

Orange Sources: View sources of
orange checks.

Sensitivity Context: For a check
that has a different color for different
function calls, view the check color for
each function call.

Improvements in search capability in the user interface

In R2015a, the Search pane allows you to search for a string in various panes of the user

interface.

To search for a string in the new user interface:

1 If the Search pane is not visible, open it. Select Window > Show/Hide View >

Search.

2 Enter your string in the search box.

From the drop-down list beside the box, select names of panes you want to search.

The Search pane consolidates the search options previously available.
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Support for GCC 4.8

Polyspace now supports the GCC 4.8 dialect for C and C++ projects.

To allow GCC 4.8 extensions in your Polyspace Code Prover verification, set Target &
Compiler > Dialect option gnu4.8.

For more information, see Dialect (C) and Dialect (C++).

Polyspace plug-in for Simulink improvements
In R2015a, there are three improvements to the Polyspace Simulink plug-in.
Integration with Simulink projects

You can now save your Polyspace results to a Simulink project. Using this feature, you
can organize and control your Polyspace results alongside your model files and folders.

To save your results to a Simulink project:

Open your Simulink project.
2 From your model, select Code > Polyspace > Options.

3 In the Polyspace parameter configuration tab, select the Save results to Simulink
project option.

For more information, see Save Results to a Simulink Project.

DRS file format changed to XML

By default, the DRS files generated in Simulink are saved in XML.

For more information, see XML File Format for Constraints

If you want to used a customized . txt DRS file, contact customer support.
Back-to-model available when Simulink is closed

In the Polyspace plug-in for Simulink, the back-to-model feature now works even when

your model is closed. When you click a link in your Polyspace results, MATLAB opens
your Simulink model and highlights the appropriate block.
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Note: This feature works only with Simulink R2013b and later.

For more information about the back-to-model feature, see Identify Errors in Simulink

Models.

Polyspace binaries being removed

The following Polyspace binaries will be removed in a future release. The binaries are

located in matlabroot/polyspace/bin. You get a warning if you run them.

Binary name

Use instead

polyspace-automatic -orange-
tester.exe

From the Polyspace environment, select Tools >

Automatic Orange Tester

polyspace-c.exe polyspace-code-prover-nodesktop -lang c

polyspace-cpp.exe polyspace-code-prover-nodesktop -lang
cpp

polyspace-remote-c.exe polyspace-code-prover-nodesktop -lang c
-batch

polyspace-remote-cpp.exe polyspace-code-prover-nodesktop -lang
cpp -batch

polyspace-remote.exe polyspace-code-prover-nodesktop -batch

polyspace-rlI-manager.exe polyspace-server-settings.exe

polyspace-spooler.exe polyspace-job-monitor.exe

polyspace-ver._exe polyspace-code-prover-nodesktop -ver

Import Visual Studio project being removed

The File > Import Visual Studio project will be removed in a future release. Instead,
use the Create from build system option during New Project creation. For more
information, see Trace Visual Studio Build.
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Detection of stack pointer dereference outside scope

In R2015a, the Illegally dereferenced pointer check can detect stack pointer
dereference outside scope. Such dereference can happen, for example, when a pointer to
a variable that is local to a function is returned from the function. Because the scope of
the variable is limited to the function, dereferencing the pointer outside the function can
cause undefined behavior.

This enhancement is not available by default. Use the option ~detect-pointer-

escape to detect such dereferences. To provide command-line options in the user
interface:

1 On the Configuration pane, select Advanced Settings.
2 Enter the option in the Other field.

Before R2015a R2015a
In the following code, ptr points to ret. In the following code, Polyspace
Because the scope of ret is limited to Code Prover produces a red Illegally

funcl, when ptr is accessed in func2, the |dereferenced pointer check on *ptr.
access is illegal. Polyspace Code Prover did

not detect such pointer escapes. void*func2(int *ptr) {
ptr = 0;
void func2(int *ptr) { }
*ptr = 0; i i
} int* funcl(void) {
int ret = 0;
int* funcl(void) { return &ret ;
int ret = 0; 1 ) )
return &ret ; void main(void) {
} int* ptr = funcl(Q ;
void main(void) { func2(ptr) ;
int* ptr = funciQ ; }

func2(ptr) ;

The Check Details pane displays a message indicating that ret is accessed outside its
scope.
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tm1: Tllegally dereferenced pointer
Error: pointer is outside its bounds

Pointer is not null,

Pointer may point to variable or field of variable:

This check may be a path-related issue, which is not dependent on input values
Dereference of parameter 'ptr' (pointer to int 32, size: 32 bits):

Points to 4 bytes at offset 0 in buffer of 4 bytes, so is within bounds (if memary is allocated).

'ret’, local to function "funcl'. ret’ is accessed outside its scope.

Isolated ellipsis for variable number of function arguments supported

In R2015a, for C++ code, Polyspace Code Prover supports the ellipsis in the function

definition syntax void foo(...){} to mean variable number of arguments. Previously,
the use of ellipsis in isolation was not supported. You could use only the syntax where the
ellipsis was preceded with other parameters.

Before R2015a

R2015a

In the following code, Polyspace considers
that foo has no arguments. Therefore, it
produces a red Correctness condition
error on the second function call. The
Check Details pane indicates that the
wrong number of arguments were used in
the function call.

void foo(.-.) {
/* Function body */
3

void main(Q) {
foo;
foo(1,2); //Red COR

}

In the following code, Polyspace considers
that foo takes a variable number of
arguments. It does not produce a red
Correctness condition error on the
second function call.

void foo(...) {
/* Function body */
}

void main(Q) {
foo();
foo(1,2); //No COR

}

Improvement in pointer comparisons

In R2015a, Polyspace is more precise on pointer comparisons. In certain cases, if the
software can determine that a pointer comparison is always true or false, it provides that
result. Previously, Polyspace did not check pointer comparisons.
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Before R2015a

R2015a

In the following code, Polyspace does not
check the comparison ptr==&invalid.
Therefore, it considers that check can
return either O or 1. In the main function,
it verifies both branches of the i f-else
statement.

#include <stdlib.h>
typedef unsigned char
U8 invalid;

#define TEST_DISABLED &invalid

us;

U8 check(U8 cnt, U8* ptr)

{
U8 ret=0;
if (ptr == &invalid)
{
ret=1;
}
return ret;
}

void main()
{ U8 isDisabled;
isDisabled = check(1U,TEST_DISABLE
if(isDisabled 1) {
/* Do not perform test */

s
else {

/* Perform test */
s

In the following code, Polyspace checks
the comparison ptr===&invalid

and determines that it is always true.
Therefore, it considers that the i F test is
redundant and the function check returns
1 only. In the main function, it verifies the
i branch and considers the else branch
as unreachable.

#include <stdlib.h>
typedef unsigned char
U8 invalid;

#define TEST DISABLED &invalid

us;

U8 check(U8 cnt, U8* ptr)

{
U8 ret=0;
if(ptr == &invalid)
{
ret=1;
}
return ret;
}

void main(Q)
{ U8 isDisabled;
isDisabled = check(1U,TEST_DISABLE
if(isDisabled 1) {
/* Do not perform test */

}
else {

/* Perform test */
}

Improvements in coding rules checking

MISRA C:2004 and MISRA AC AGC

D);
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Rule Number Effect More Information

Rule 12.6 More results on noncompliant MISRA C:2004 Rules — Chapter
#1T preprocessor directives 12: Expressions
Fewer results for variables cast
to effective Boolean types.

Rule 12.12 Fewer results when converting to [MISRA C:2004 Rules — Chapter
an array of Float 12: Expressions

MISRA C:2012

Rule Number

Effect

More Information

Rules 10.3

Fewer results on enumeration
constants when the type of the
constant is a named enumeration
type.

Fewer results on user-defined
effective Boolean types.

MISRA C:2012 Rule 10.3

Rule 10.4

Fewer results on enumeration
constants when the type of the
constant is a named enumeration
type.

Fewer results for casts to user-
defined effective Boolean types.

MISRA C:2012 Rule 10.4

Rule 10.5

Fewer results on enumeration
constants when the type of the
constant is a named enumeration
type.

Fewer results on user-defined
effective Boolean types.

MISRA C:2012 Rule 10.5

Rule 12.1

More results on expressions
with sizeof operator and on
expressions with ? operators.
Fewer results on operators of
the same precedence and in
preprocessing directives.

MISRA C:2012 Rule 12.1

Rule 14.3

No results for non-controlling
expressions.

MISRA C:2012 Rule 14.3
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MISRA C++:2008

Rule Number Effect More Information

Rule 5-0-3 Fewer results on enumeration MISRA C++ Rules — Chapter 5
constants when the type of the
constant is the enumeration type.

Rule 6-5-1 Fewer results on compliant vector | MISRA C++ Rules — Chapter 6
variable iterators.

Rule 14-8-2 Fewer results for functions MISRA C++ Rules — Chapter 14
contained in the Files and folders
to ignore (C++) option.

Rule 15-3-2 Fewer results for user-defined MISRA C++ Rules — Chapter 15

return statements after a try
block.
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Context-sensitive help for code complexity metrics, MISRA-C:2012, and
custom coding rules

In R2015a, context-sensitive help is available in the user interface for code complexity
metrics, MISRA C:2012 rule violations, and custom coding rule violations.

To access the contextual help, see Getting Help.
For information about these results, see:

* Code Metrics
+ MISRA C:2012 Directives and Rules
* Custom Coding Rules

Review of code complexity metrics and global variable usage in user
interface

* “Code Complexity Metrics” on page 4-11
* “Global Variables” on page 4-12

Code Complexity Metrics

In R2015a, you can view code complexity metrics in the Polyspace user interface. For
more information, see Code Metrics. Previously, this information was available only in
the Polyspace Metrics web interface.

In the user interface, you can:

*  Specify a limit for the value of a metric. If the metric value for your source code
exceeds this limit, the metric appears red on the Results Summary pane.

+ Justify the value of a metric. If a metric value exceeds specified limits and appears
red, you can add a comment with the rationale.

Combining these actions, you can enforce coding standards across your organization. For
more information, see Review Code Metrics.

Reducing the complexity of your code improves code readability, reduces the possibility of
coding errors, and allows more precise Polyspace verification.
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Global Variables

In R2015a, you can comment and justify global variable usage on the Results Summary
pane. Previously, you viewed global variable usage on the Variable Access pane, but
could not comment on them.

On the Results Summary pane, global variables are classified into one of the following
categories.

Category Color Meaning

Shared Potentially Orange Global variables
unprotected shared between
multiple tasks

but possibly not
protected from
concurrent access by
the tasks

Protected Green Global variables
shared between
multiple tasks and
protected from
concurrent access by
the tasks

Not shared Used Black Global variables
used in a single task

Unused Gray Global variables
declared but not
used

For more information, see Global Variables.

For code that you do not intend for multitasking, all variables are nonshared and can be
either used or unused. For code that you intend for multitasking, you can specify tasks
and protections through the analysis options for multitasking. For more information, see
Multitasking.

You can still view the global variables on the Variable Access pane.

+ To comment and justify potentially unprotected and unused global variables, use the
Results Summary pane.
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* To find the read and write operations on a global variable, use the Check Details or
Variable Access pane. On the Variable Access pane, you can also see the variable
range and other information.

For more information, see Review Global Variable Usage.

Review of latest results compared to the last run
In R2015a, you can review only new results compared to the previous run.

If you rerun your verification, the new results are displayed with an asterisk (¥*) against
them on the Results Summary pane. To filter only these new checks, select the New
results box.

If you make changes in your source code, you can use this feature to see only the checks
introduced due to those changes. You can avoid reviewing checks in the source code that
you did not change.

Guidance for reviewing Polyspace Code Prover checks in C code

In R2015a, the context-sensitive help for checks provides guidance about how to review
the check. The help describes:

+ Information available in the software for the check.
* In your source code, how to navigate to the root cause of the check.

*  Common causes of the check.
To open the context-sensitive help for a check:

*  On the Results Summary or Source pane, select the check.

Select the “L¥ button.
* Select the link in the section Diagnosing This Check.

This additional guidance is not available for C++-specific checks.

Simplified results infrastructure

Polyspace results folders are reorganized and simplified. Files have been removed,
combined, renamed, or moved. The changes do not affect the results that you see in the
Polyspace environment.
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Some important changes and file locations:

The main results file is now encrypted and renamed ps_results.pscp. You can
view results only in the Polyspace environment.

The log file, Polyspace_R2015a_project date-time.log has not changed.

For more information, see Results Folder Contents.
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Improved verification speed

In R2014b, the following two changes improve the verification speed:

* Polyspace Code Prover can run the compilation phase of your verification in parallel
on multiple processors. The software detects available processors and uses them to
compile different source files in parallel.

Previously, the software ran post-compilation phases in parallel but compiled the
source files sequentially. Starting in R2014b, the software can use multiple processors
for the entire verification process.

To explicitly specify the number of processors, use the command-line option -max-
processes. For more information, see -max-processes.

+ Polyspace Code Prover has an improved engine for verification. This engine typically
improves verification speed by 25%. However, in some cases, verification can take the
same amount of time or longer.

Compatibility Considerations

In most cases, you do not see significant change in the number of checks resulting from
the improved engine. If you see a major increase in the number of orange checks, contact
technical support. For more information, see Obtain System Information for Technical
Support.

Support for Mac OS

You can install and run Polyspace on Mac OS X. Polyspace is supported for Mac OS
10.7.4+, 10.8, and 10.9.

You can use Polyspace Metrics on Safari and set up your Mac as a Metrics server.
However, if you restart your Mac machine that is setup as a Metrics server, you must

restart the Polyspace server daemon.

The Automatic Orange Tester is not supported for Mac.
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Support for C++11

Polyspace can now fully analyze C++ code that follows the ISO/IEC 14882:2011 standard,
also called C++11.

Use two new analysis options when analyzing C++11 code. On the Target & Compiler
pane, select:

* C++11 extensions to allow the standard C++11 libraries and functions during your
analysis.

* Block char 16/32_t types to not allow charl6_t or char32_t types during the
analysis.

For more information, see C++11 Extensions (C++) and Block char16/32_t types (C++).

Code Editor for editing source files in Polyspace user interface

In R2014b, by default, you can edit your source files inside the Polyspace user interface.

* In the Project Manager perspective, on the Project Browser tree, double-click your
source file.

* In the Results Manager perspective, right-click the Source pane and select Open
Source File.

Your source files appear on a Code Editor tab. On this tab, you can edit your source
files and save them.

To use an external text editor, change your preferences.

1 Select Tools > Preferences.

2 Specify an external editor on the Editors tab.

For more information, see Specify External Text Editor.

Local file-by-file verification

In R2014b, you can verify your source code file by file on your local installation of
Polyspace Code Prover. Each file is verified independently of the other files in your
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module. Previously, you performed file-by-file verification only on a remote server. The
verification required:

+ Parallel Computing Toolbox™ on the client side

+ MATLAB Distributed Computing Server™ on the server side

For more information on file-by-file verification, see:

*  Run File-by-File Verification
*  Open Results of File-by-File Verification

For information on file-by-file verification in batch mode, see:

* Run File-by-File Batch Verification
*  Open Results of File-by-File Batch Verification
Simulink plug-in support for custom project files

With the Polyspace plug-in for Simulink, you can now use a project file to specify the
verification options.

On the Polyspace pane of the Configuration Parameters window, with the Use custom
project file option you can enter a path or browse for a . psprj project file.

For more information, see Configure Polyspace Analysis Options.

Targetlink support updated

The Polyspace plug-in for Simulink now supports TargetLink 3.4 and 3.5. Older versions
of TargetLink are not supported.

For more information, see TargetLink Considerations.

AUTOSAR support added

In R2013b, the Polyspace plug-in for Simulink added support for AUTOSAR generated
code with Embedded Coder”. If you use autosar .tlc as your System target file
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for code generation, when you run Polyspace, the verification can use the data range
information from AUTOSAR.

The Polyspace verification uses the same default options and parameters as it does for
Embedded Coder.

For more information, see Embedded Coder Considerations.

Default verification level changed

In R2014b, unless you specify a verification level explicitly, Polyspace Code Prover
verification performs two passes on your source code instead of four. For instance:

* In the user interface, on the OQutput Summary tab, you can see that the verification
continues to Level2. For more passes, on the Configuration pane, under the
Precision node, select a higher Verification level.

* At the command line, the verification implicitly uses -to pass2. For more passes,
use the -to option explicitly with a higher pass value.

The default verification is completed in much less time.

For more information, see:

* Verification level (C)

« Verification level (C++)

Compaitibility Considerations

If you do not specify a verification level explicitly in your polypsace-code-prover-
nodesktop command, your verification runs to Software Safety Analysis Level
2. In most cases, this verification level produces only slightly more orange checks than
Software Safety Analysis Level 4. However, if you see a significant change in
your results, to reproduce your earlier results:

* In the user interface, select Software Safety Analysis Level 4 for
Verification level.

+ At the command line, use the option -to pass4 with the polypsace-code-
prover-nodesktop command.
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Default mode changed for C++ code verification in user interface

When you create a new Polyspace Code Prover project with C++ as the project language,
the following options are selected in the user interface by default. The options appear on
the Configuration pane under the Code Prover Verification node.

Option Valve
Verify Module On
Class all
Functions to call within the specified |unused
classes

Functions to call unused
Variables to initialize uninit

These options replace the default selection of Verify whole application on the
Polyspace user interface.

If your C++ code does not contain a main function, Polyspace generates a main by default
during verification from the user interface.

For more information on the main generation options, see Provide Context for C++ Code
Verification.

Improved global menu in user interface

The global menu in the Polyspace user interface has been updated. The following table
lists the current location for the existing global menu options.

Godl Prior to R2014b R2014b

Open the Polyspace Metrics |File > Open Metrics Web |Metrics > Open Metrics
interface in your web Interface

browser.

Upload results from the File > Upload in Metrics > Upload to
Polyspace user interface to |Polyspace Metrics Metrics

Polyspace Metrics. repository

Update results stored in File > Save in Polyspace |Metrics > Save comments
Polyspace Metrics with Metrics repository to Metrics
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Goal

Prior to R2014b

R2014b

your review comments and
justifications.

Generate a report from
results after verification.

Run > Run Report > Run
Report

Reporting > Run Report

Open generated report.

Run > Run Report >
Open Report

Reporting > Open Report

Partition source code into
modules.

Run > Run Modularize

Tools > Run Modularize

Import review comments
from previous verification.

Review > Import

Tools > Import Comments

Specify code generator for
generated code.

Review > Code
Generator Support

Tools > Code Generator
Support

Specify settings that apply
to all Polyspace Code Prover
projects.

Options > Preferences

Tools > Preferences

Specify settings for remote
verification.

Options > Metrics and
Remote Server Settings

Metrics > Metrics and
Remote Server Settings

Improved Project Manager perspective

The following changes have been made in the Project Manager perspective:

+ The Progress Monitor tab does not exist anymore. Instead, after you start a
verification, you can view its progress on the OQutput Summary tab.

+ Instead of a single progress bar showing all the stages of verification, you can see two
progress bars. The top bar shows progress in the current stage of verification and the
lower bar shows overall progress.

Level2: 0%

Elapsed time: 00:00:00

Total: 75% Total elapsed time: 00:00:17

After verification, you can see the overall time taken. To see the time taken in each

stage of verification, click the @ icon.
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* In the Project Browser, projects appear sorted in alphabetical order instead of order
of creation.

Changed analysis options

Changes have been made to the following analysis options:

*  On the Configuration pane, the analysis option Files and folders to ignore has
been moved from Coding Rules Checking to Inputs & Stubbing. The functionality
in Polyspace Code Prover has not changed.

*  On the Configuration pane, the Interactive option has been removed from the
graphical interface. To use interactive mode, use the —interactive flag at the
command line or in the Advanced Settings > Other text field.

*  You cannot use batch mode or interactive mode with Verification Level > C/C++
source compliance checking.

To run only to code compliance, run Polyspace Code Prover locally.

To perform batch or interactive verifications, use Software Safety Analysis level 0
or higher.

Remote launcher and queue manager renamed

Polyspace has renamed the remote launcher and the queue manager.

Previous name New Name More information
polyspace-rl-manager.exe |polyspace-server- Only the binary name has
settings.exe changed. The interface

title, Metrics and Remote
Server Settings, is
unchanged.

polyspace-spooler._exe polyspace-job-monitor.exe The binary and the

interface titles have
changed. Interface labels
have changed in the
Polyspace interface and its
plug-ins.

Queue Manager or Spooler Job Monitor

pslinkfun("queuemanager®) |pslinkfun(”jobmonitor™) See pslinkfun.
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Compatibility Considerations

If you use the old binaries or functions, you receive a warning.

Polyspace binaries being removed

The following Polyspace binaries will be removed in a future release. Unless otherwise
noted, the binaries to use are located in matlabroot/polyspace/bin.

Binary name What Use instead
happens
polyspace-automatic -orange- Warning | From the Polyspace environment, select Tools
tester.exe > Automatic Orange Tester
polyspace-c.exe Warning |polyspace-code-prover-nodesktop -
lang c
polyspace-cpp.-exe Warning |polyspace-code-prover-nodesktop -
lang cpp
polyspace-remote-c.exe Warning |polyspace-code-prover-nodesktop -
lang c -batch
polyspace-remote-cpp.exe Warning |polyspace-code-prover-nodesktop -
lang cpp -batch
polyspace-remote.exe Warning |polyspace-code-prover-nodesktop -
batch
polyspace-rlI-manager.exe Warning |polyspace-server-settings.exe
polyspace-spooler.exe Warning |polyspace-job-monitor.exe
polyspace-ver .exe Warning |polyspace-code-prover-nodesktop -ver
setup-remote-launcher .exe Warning i[matlabroot/toolbox/polyspace /

psdistcomp/bin/setup-polyspace-
cluster

Import Visual Studio project being removed

The File > Import Visual Studio project will be removed in a future release. Instead,
use the Create from build system option during New Project creation. For more
information, see Trace Visual Studio Build.
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Verification Results

Support for MISRA C:2012

Polyspace can now check your code against MISRA C:2012 directives and coding rules. To
check for MISRA C:2012 coding rule violations:

1 On the Configuration pane, select Coding Rules.
2 Select Check MISRA C:2012.

3 The MISRA C:2012 guidelines have different categories for handwritten and
automatically generated code.

If you want to use the settings for automatically generated code, also select Use
generated code requirements.

For more information about supported rules, see MISRA C:2012 Coding Directives and
Rules.

Improved verification precision for non-initialized variables

Polyspace Code Prover performs the following checks for initialization:

* Non-initialized local variable or NIVL

* Non-initialized variable or NIV
In R2014b, the following changes appear in these checks.
Read Operations on Structures

When you read structured variables, Polyspace Code Prover performs a check for
initialization. This check helps detect partially initialized and non-initialized structures
earlier in the code.

Prior to R2014b R2014b
*  When you read structured variable, When you read structured variables, a
a check for initialization was not check for initialization occurs. The check
performed. turns:
The checks occurred only when you
read individual fields of a structured
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Prior to R2014b

R2014b

variable, provided the fields themselves
were not structured variables.

Green, if all fields of the structure that
are used are initialized. If no field is
used, the check is green by default.

+ Red, if all fields that are used are not
initialized.

* Orange, if only some fields that are
used are initialized. Following the
check, Polyspace considers that the
uninitialized fields have the full range
of values allowed by their type.

Polyspace considers a field as used if there
is a read or write operation on the field
anywhere in the code. Polyspace does not
check for initialization of fields that are not
used.

To determine which fields Polyspace
checked for initialization:

1  Select the NIV or NIVL check on the
Results Summary pane or Source
pane.

2 View the message on the Check
Details pane.
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Prior to R2014b

R2014b

Example:

typedef struct S {
int a;
int b;

}S;

void funcl(S);
void func2(int);

void main() {
S varsS;
funcl(varS);
func2(varS.a);

}

A check was not performed when the non-
initialized structure varS was read. When
the field a of varS was read, a red NIVL
check appeared.

Example:

typedef struct S {
int a;
int b;

}S;

void funcl(S);
void func2(int);

void main() {
S vars;
funcl(varS);
func2(varS.a);

}

When the non-initialized structure vars is
read, a red NIVL check appears.

For more examples, see:

+ Partially initialized structure — All
used fields initialized

+ Partially initialized structure — Some
used fields initialized

Other Operations

The specification of Non-initialized variable checks has changed for the following
operations. These operations are not commonly used. Therefore, it is likely that these
changes do not affect your Polyspace verification.

Prior to R2014b

R2014b

If you initialized only the high bits of a
variable through a pointer, an orange
check for initialization appeared when the
variable was read.

If you initialize only the high bits of a
variable through a pointer, a green check
for initialization appears when the variable
is read.

If you performed an operation on a C++
object after it was destroyed, a red check

for initialization appeared on the operation.

If you perform an operation on a C++
object after it is destroyed, the check
for initialization has the same color as
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Prior to R2014b R2014b
The check indicated that the object was before the destruction. Polyspace does not
destroyed. introduce a red check on this type of access.

Compatibility Considerations

If you use an earlier version of Polyspace Code Prover, it is possible that you see the
following changes in your results.

* Read operation on structures: You see an increase in the total number of checks.

However, some red or orange NIV or NIVL checks on the fields of structures turn
green. Instead, you see some new red or orange checks on the structures themselves.

*  Other operations:

+ If you have operations that initialize only the high bits of a variable through a
pointer, you can see a reduction in orange NIV or NIVL checks.

If you have operations that access an object after it is destroyed, you can see a
reduction in red NIV or NIVL checks.

New checks for functions not called

Two new checks in Polyspace Code Prover detect C/C++ functions that are defined but
not called during execution of the code.

Check Purpose

Function not called Detects functions that are defined but not
called in the source files.

Function not reachable Detects functions that are defined but
called only from an unreachable part of the
source.

You can choose to activate these checks using the following options:

+ In the user interface, on the Configuration pane, under Check Behavior, select a
value for the option Detect uncalled functions.

+ At the command line, use the option —uncal led-function-checks with an
appropriate argument.
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Godl Option Value

Do not detect uncalled functions. none

Detect functions that are defined but not never-called
called.

Detect functions that are defined and called |cal led-from-unreachable
only from an unreachable part of the code.

Detect all uncalled functions. all

Improved precision level

In R2014b, certain internal limits have been removed from verification that uses a
Precision level of 3. Because of this improvement, you can use this Precision level
to significantly reduce orange checks, especially for multitasking code that uses shared
variables. However, if you use this level, the verification can take significantly longer.

To set Precision level to 3, do one of the following:

* In the user interface, on the Configuration pane, select Precision. From the
Precision level drop-down list, select 3.

* At the DOS or UNIX® command prompt, use the flag -03 with the polyspace-
code-prover-nodesktop command.

+ At the MATLAB command prompt, use the argument "-03" with the
polyspaceCodeProver function.

For more information, see Precision level (C/C++).
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Context-sensitive help for verification options and checks

In R2014b, contextual help is available for verification options in the Polyspace interface
and its plug-ins. To view the contextual help:

1  Hover your cursor over a verification option in the Configuration pane.
2 Inside the tooltip, select the “More Help” link.

The documentation for that option appears in a dockable window.

Contextual help is available in the Polyspace interface for run-time errors. To view the
contextual help for checks:

1 In the Results Manager perspective, select a run-time error from the results.

Inside the Check Details pane, select 1/
The documentation for that check appears in a docked window.

For more information, see Getting Help.

Updated Software Quality Objectives

In R2014b, the Software Quality Objectives or SQOs have been updated to include
MISRA C++: 2008 coding rule violations.

Using the predefined SQO levels, you can specify quality thresholds for your project or
individual files in your project. With the updated SQOs, you can now specify that your
project must not violate certain MISRA C++ rules.

For more information, see Predefined SQO Levels.

Improved Results Manager perspective
The following changes have been made in the Results Manager perspective:
*  On the Source pane, the following code appears in gray:

Code deactivated due to conditional compilation. Polyspace assigns a lighter shade
of gray to this code.

5-15


http://www.mathworks.com/help/releases/R2014b/codeprover/gs/getting-help.html
http://www.mathworks.com/help/releases/R2014b/codeprover/ug/predefined-sqo-levels.html

R2014b

+ Code in an unreachable branch. Polyspace assigns a darker shade of gray to this
code.

For the difference between the two cases, see the code below. To reproduce the
colors, before verification, on the Configuration pane, enter Polyspace= for
Preprocessor definitions.

[ A4 source
Dashboard = |test file.c x

#include <limits.h>
int getWVal():

void main{) [

int a=getVal(),b;

#ifdef Polyspace

#elae

#endif

+ To prioritize your orange check review, use the Show menu on the Results
Summary pane. This menu replaces the previously available methodologies for the
same purpose.

+ To display red, gray, and orange checks likely to be run-time errors, from the
Show menu, select Critical checks. This option replaces the First checks to
review methodology.

+ To display all checks, from the Show menu, select All checks. This option
replaces the All checks methodology.
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+ The methodologies Methodology for C/C++ > Light and Methodology for C/C+
+ > Moderate have been removed.
To create your own subset of orange checks to review, select Tools > Preferences.
On the Review Scope tab, specify the number or percentage of orange checks of
each type to review. The options on this tab replace the options on the Review
Configuration tab.

To group your checks, use the Group by menu on the Results Summary pane.

* To leave your checks ungrouped, instead of List of Checks, select Group by >
None.

+ To group checks by check color and type, instead of Checks by Family, select
Group by > Family.
To group checks by file and function, instead of Checks by File/Function, select
Group by > File.

To view the percentage of checks that you have justified, instead of the Review
Statistics pane, use the Justified column on the Results Summary pane. On this
pane:

+ To view the percentage of checks that you justified broken down by color/type,
select Group by > Family.

To view the percentage of checks that you justified broken down by file/function,
select Group by > File.

Error mode removed from coding rules checking

In R2014b, the Error mode has been removed from coding rules checking. Therefore,
coding rule violations cannot stop a verification.

Compatibility Considerations

For existing coding rules files, rules having the keyword error are treated in the same
way as the keyword warning. For more information on warning, see Format of Custom
Coding Rules File.
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Automatic project setup from build systems

In R2014a, you can set up a Polyspace project from build automation scripts that you use
to build your software application. The automatic project setup runs your automation
scripts to determine:

*  Source files.

* Includes.

+ Target & Compiler options.

To set up a project from your build automation scripts:

*  On the DOS or UNIX command line: Use the polyspace-configure command. For
more information, see Create Project from DOS and UNIX Command Line.

* In the user interface: When creating a new project, in the Project — Properties
window, select Create from build command. In the following window, enter:
*  The build command that you use.
* The directory from which you run your build command.

+ Additional options. For more information, see Create Project in User Interface.

Click M In the Project Browser, you see your new Polyspace project with
the required source files, include folders, and Target & Compiler options.

* On the MATLAB command line: Use the polyspaceConfigure function. For more
information, see Create Project from MATLAB Command Line.

Support for GNU 4.7 and Microsoft Visual Studio C++ 2012 dialects

Polyspace supports two additional dialects: Microsoft Visual Studio C++ 2012 and GNU®
4.7. If your code uses language extensions from these dialects, specify the corresponding

analysis option in your configuration. From the Target & Compiler > Dialect menu,
select:

+ gnu4.7 for GNU 4.7
* visualll.0 for Microsoft Visual Studio C++ 2012
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For more information about these and other supported dialects, see Dialects for C or
Dialects for C++.

Documentation in Japanese
The Polyspace product, including the documentation, is available in Japanese.
To view the Japanese version of Polyspace Code Prover documentation, go to http://

www.mathworks.co.jp/jp/help/codeprover/. If the documentation appears in English, from
the country list beside the globe icon at the top of the page, select Japan.

Preferences file moved

In R2014a, the location of the Polyspace preferences file has been changed.

Operating Location before R2014a Location in R2014a

System

Windows %APPDATA%\Polyspace %APPDATA%\MathWorks\MATLAB\R2014a
\Polyspace

Linux /home/$USER/ .polyspace |/home/$USER/ .matlab/$RELEASE/Polyspace

For more information, see Storage of Polyspace Preferences.

Support for batch analysis security levels

When creating an MDCS server for Polyspace batch analyses, you can now add
additional security levels through the MATLAB Admin Center. Using the Metrics
and Remote Server Settings, the MDCS server is automatically set to security level
zero. If you want additional security for your server, use the Admin Center button. The
additional security levels require authentication by user name, cluster user name and
password, or network user name and password.

For more information, see MDCS documentation.

Interactive mode for remote verification

In R2014a, you can select an additional Interactive mode for remote verification. In this
mode, when you run Polyspace Code Prover on a cluster, your local computer is tethered
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to the cluster through Parallel Computing Toolbox and MATLAB Distributed Computing
Server.

To run verification in this mode

* In the user interface: On the Configuration pane, under Distributed Computing,
select Interactive.

*  On the DOS or UNIX command line, append -interactive to the polyspace-
code-prover-nodesktop command.

*  On the MATLAB command line, add the argument "-interactive” to the
polyspaceCodeProver function.

For more information, see Interactive.

Default text editor

In R2014a, Polyspace uses a default text editor for opening source files. The editor is:

* WordPad in Windows

* viin Linux

You can change the text editor on the Editors tab under Options > Preferences. For

more information, see Specify Text Editor.

Support for Windows 8 and Windows Server 2012

Polyspace supports installation and analysis on Windows Server® 2012 and Windows 8.

For installation instructions, see Installation, Licensing, and Activation.

Check model configuration automatically before analysis

For the Polyspace Simulink plug-in, the Check configuration feature has been
enhanced to automatically check your model configuration before analysis. In the
Polyspace pane of the Model Configuration options, select:

*+ On, proceed with warnings to automatically check the configuration before
analysis and continue with analysis when only warnings are found.

+ 0On, stop for warnings to automatically check the configuration before analysis
and stop if warnings are found.
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+ OFfF to never check the configuration automatically before an analysis.

If the configuration check finds errors, Polyspace always stops the analysis.

For more information about Check configuration, see Check Simulink Model Settings.

Function replacement in Simulink plug-in

The following functions have been replaced in the Simulink plug-in by the function
pslinkfun. These functions be removed in a future release.

Function What Use This Function Instead

Happens?
PolyspaceAnnotation Warning pslinkfun("annotations®,...)
PolySpaceGetTemplateCFGFile Warning pslinkfun(“gettemplate®)
PolySpaceHelp Warning pslinkfun("help™)
PolySpaceEnableCOMServer Warning pslinkfun(~enablebacktomodel *)
PolySpaceSpooler Warning pslinkfun(®queuemanager")
PolySpaceViewer Warning pslinkfun("openresults®,...)
PolySpaceSetTemplateCFGFile Warning pslinkfun(“settemplate®,...)
PolySpaceConfigure Warning pslinkfun("advancedoptions®)
PolySpaceKillAnalysis Warning pslinkfun("stop”)
PolySpaceMetrics Warning pslinkfun("metrics”)

Polyspace binaries being removed

The following Polyspace binaries will be removed in a future release:

+ polyspace-automatic-orange-tester.exe

+ polyspace-c.exe
+ polyspace-cpp.exe

+ polyspace-modularize.exe

+ polyspace-remote-c.exe

+ polyspace-remote-cpp.exe
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polyspace-remote.exe
polyspace-report-generator.exe
polyspace-results-repository.exe
polyspace-rl-manager.exe
polyspace-spooler.exe
polyspace-ver._exe
setup-remote-launcher ._exe
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Support for additional Coding Rules (MISRA C:2004 Rule 18.2, MISRA C+
+ Rule 5-0-11)

The Polyspace coding rules checker now supports two additional coding rules: MISRA C
18.2 and MISRA C++ 5-0-11.

+ MISRA C 18.2 is a required rule that checks for assignments to overlapping objects.

+ MISRA C++ 5-0-11 is a required rule that checks for the use of the plain char type as
anything other than storage or character values.

* MISRA C++ 5-0-12 is a required rule that checks for the use of the signed and
unsigned char types as anything other than numerical values.

For more information, see MISRA C:2004 Coding Rules or MISRA C++ Coding Rules.

Improvement of floating point precision

In R2013b, Polyspace improved the precision of floating point representation. Previously,
Polyspace represented the floating point values with intervals, as seen in the tooltips.
Now, Polyspace uses a rounding method.

For example, the verification represents Float arr = 0.1; as,

+ Pre-R2013b, arr = [9.9999E~-2,1.0001E-1].
+ Now,arr = 0.1.
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Results folder appearance in Project Browser

In R2014a, the results folder appears in a simplified form in the Project Browser.
Instead of a folder containing several files, the result appears as a single file.

Format before R2014a:

= Demo_C [C]
'Ij Source
'ﬁ Include
=3 Module_1
'ﬁ Source
-1 .3 Configuration
El'lj Result
-7 Result_1 [Verification Completed]
-Iﬁ options
'._. MISEA-C-report.xml
- || Custem-rules-report.xml

Format in R2014a:

=3 Demo_C[C]
"j Source
-3 Include
=3 Module_1
'Ij Source
"j Configuration
El'ﬁ Result

RdfResult 1 [Verification Completed]

The following table lists the changes in the actions that you can perform on the results
folder.
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Action

2013b

2014a

Open results.

In the result folder, double-
click result file with extension

.pscp.

Double-click result file.

Open analysis options used for
result.

In the result folder, select
options.

Right-click result file and select
Open Configuration.

Open metrics page for batch
analyses if you had used the
analysis option Distributed
Computing > Add to results
repository.

In the result folder, select
Metrics Web Page.

Double-click result file.

If you had used the option
Distributed Computing >
Add to results repository,
double-clicking the results file
for the first time opens the
metrics web page instead of the
Result Manager perspective.

Open results folder in your file
browser.

Navigate to results folder.

To find results folder location,
select Options > Preferences.
View result folder location

on the Project and Results
Folder tab.

Right-click result file and
select Open Folder with File
Manager.

Results Manager improvements

* In R2014a, you can view the extent of a code block on the Source pane by clicking
either its opening or closing brace.
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v il L]

Dashboard ¢ |tasksl.c = 1 [ B
gtatic wvoid initregqulate (wvoid) =~

{
int tmp = 0O;
while ({random int({) < 1I'_'IEII'_'I:|\[|:I)

tmp = orderregulate(];

End CS{):
tmp = Get PowerLevel():
Compute Injection{):
1 /* end loop; */
} il

1 k

| |'¥| Source | [L.]] Data Range Configuration

Note: This action does not highlight the code block if the brace itself is already
highlighted. The opening brace can be highlighted, for instance, if there is an
Unreachable code error on the code block.

In R2014a, the Verification Statistics pane in the Project Manager and the Results
Statistics pane in the Results Manager have been renamed Dashboard.

On the Dashboard, you can obtain an overview of the results in a graphical format.
For more information, see Dashboard.

In R2014a, on the Results Summary pane, you can distinguish between violations of
predefined coding rules such as MISRA C or C++ and custom coding rules.
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The predefined rules are indicated by = .

The custom rules are indicated by * .

In addition, when you click on the Check column header on the Results Summary
pane, the rules are sorted by rule number instead of alphabetically.

+ In R2014a, you can double-click a variable name on the Source pane to highlight all
instances of the variable.

Simplification of coding rules checking

In R2014a, the Error mode has been removed from coding rules checking. This mode
applied only to:

* The option Custom for:

Check MISRA C rules
Check MISRA AC AGC rules
Check MISRA C++ rules
Check JSF C++ rules

* Check custom rules

The following table lists the changes that appear in coding rules checking.

Coding Rules
Feature

2013b

2014a

New file wizard
for custom
coding rules.

For each coding rule, you can select three
results:

+  Error: Analysis stops if the rule is
violated.

The rule violation is displayed on the
Output Summary tab in the Project
Manager perspective.

+ Warning: Analysis continues even if
the rule is violated.

For each coding rule, you can select
two results:

*  On: Analysis continues even if
the rule is violated.

The rule violation is displayed on
the Results Summary pane in
the Result Manager perspective.

+ Off: Polyspace does not check for
violation of the rule.
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Coding Rules 2013b 2014a
Feature

The rule violation is displayed on the
Results Summary pane in the Result
Manager perspective.

+  Off: Polyspace does not check for
violation of the rule.

Format of the Each line in the file must have the syntax: | Each line in the file must have the
custom coding i syntax:
e E e rule off|error|warning #comments

rule off|warning #comments
For example:

) ) ) For example:
# MISRA configuration - Projl

10.5 off #don"t check 10.5 # MISRA configuration - Projl
17.2 error 10.5 off #don"t check 10.5
17.3 warning 17.2 warning

17.3 warning

Compatibility Considerations
For existing coding rules files that use the keyword error:

+ If you run analysis from the user interface, it will be treated in the same way as the
keyword warning. The verification will not stop even if the rule is violated. The rule
violation will however be reported on the Results Summary pane.

* If you run analysis from the command line, the verification will stop if the rule is
violated.

Additional back-to-model support for Simulink plug-in

As you click the different links, the corresponding block is highlighted in the
model. Because of internal improvements, the back-to-model feature is more stable.

Additionally, support has been added for Stateflow® charts in Target Link and Linux
operating systems.

For more information about the back-to-model feature, see Identify Errors in Simulink
Models.
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Proven absence of certain run-time errors in C and C++ code

Use Polyspace Code Prover to prove the absence of overflow, divide-by-zero, out-of-
bounds array access, and certain other run-time errors in source code. To verify code,

the software uses formal methods-based abstract interpretation techniques. The code
verification is static. It does not require program execution, code instrumentation, or test
cases. Before compilation and test, you can verify handwritten code, generated code, or a
combination of these two types of code.

Identification of variables exceeding specified range limits

By default, Polyspace Code Prover performs a robustness verification of your code. The
verification proves that the software works under all conditions. As the verification
assumes that all data inputs are set to their full range, almost any operation on these
inputs can produce an overflow.

To prove that your code works in normal conditions, use the Data Range Specification
(DRS) feature to perform contextual verification. You can set constraints on data ranges,
and verify your code within these ranges. The use of DRS can substantially reduce the
number of orange checks in verification results.

You can use DRS to set constraints on:

* Global variables
* Input parameters for user-defined functions called by the main generator

*  Return values for stub functions

For a global variable, if you specify the globalassert mode, the software generates a
warning when the variable exceeds your specified range.

For more information, see Data Range Configuration.

Graphical display of variable reads and writes

A Polyspace Code Prover verification generates a data dictionary with information
about global variables and the read and write access operations on these variables. You
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can view this information through the Variable Access pane of the Results Manager
perspective.

For more information, see Exploring Results Manager Perspective.

Calculation of range information for variables, function parameters and
return values

Polyspace Code Prover calculates and displays range information associated with, for
example, variables, function parameters and return values, and operators. The displayed
range information represents a superset of dynamic values, which the software computes
using static methods.

For more information, see Interpret Results.

7-3


http://www.mathworks.com/help/releases/R2013b/codeprover/ug/exploring-results-manager-perspective.html
http://www.mathworks.com/help/releases/R2013b/codeprover/results-understanding.html

R2013b

Reviewing Results

7-4

Color-coding of run-time errors directly in code
Polyspace Code Prover uses color coding to indicate the status of code elements.

* Green — Proved to never have a run-time error.
* Red — Proved to always have a run-time error.
*  Gray — Proved to be unreachable, which can indicate a functional issue.

* Orange — Unproven, and can have an error.
Errors detected include:

*  Overflows, underflows, divide-by-zero, and other arithmetic errors
* Out-of-bounds array access and illegally dereferenced pointers

+ Always true/false statement due to dataflow propagation

* Read access operation on uninitialized data

* Dead code

* Accesstonull this pointer (C++)

*  Dynamic errors related to object programming, inheritance, and exception handling
(C++)

*  Uninitialized class members (C++)

*  Unsound type conversions

For more information, see Interpret Results.

Quality metrics for tracking conformance to software quality objectives

You can define a quality model with reference to coding rule violations, code complexity,
and run-time errors. By observing these metrics, you can track your progress toward
predefined software quality objectives as your code evolves from the first iteration to the
final version.

By confirming the absence of certain run-time errors and measuring the rate of
improvement in code quality, Polyspace Code Prover enables developers, testers, and
project managers to produce, assess, and deliver code that is free of run-time errors.

For more information, see Quality Metrics.
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Web-based dashboard providing code metrics and quality status

Polyspace Code Prover provides Polyspace Metrics, a Web-based dashboard for tracking
submitted verification jobs, reviewing progress, and viewing the quality status of your
code. Polyspace Metrics provides an integrated view of project metrics, displaying code
complexity, coding rule violations, run-time errors, and other code metrics.

For more information, see Quality Metrics.

Guided review-checking process for classifying results and run-time error
status

In the Results Manager perspective, Polyspace Code Prover provides you with several
options to organize your review process.

* You can use review methodologies to specify the number and type of checks displayed
on the Results Summary pane. With each methodology, you review only a subset of
checks.

For example, if you are reviewing verification results for the first time, select First
checks to review. The software displays all red and gray checks but only a subset of
orange checks. These orange checks are the ones most likely to be run-time errors. For
more information, see Review Checks Using Predefined Methodologies.

*  You can group checks by File/Function or Check:

*  Grouping by Check classifies checks by color. Within each color, this grouping
classifies checks by categories related to the origin of the check, such as Control
flow, Data flow, and Numerical.

Grouping by File/Function classifies checks by the file where they originated.
Within each file, this grouping classifies checks by functions where they
originated.

*  For C++ files, you can also group checks by Class. This grouping classifies checks
by the class definition where they originated.
For more information, see Organize Check Review Using Filters and Groups.

* You can filter checks using any of the column information criteria on the Results
Summary pane. For example, you can filter out checks that you have already
justified using the filter icon on the Justified column header. If you have applied
a filter, the column heading changes to indicate that all results are not displayed.
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You can also define custom filters. For more information, see Organize Check Review
Using Filters and Groups.

* You can navigate through the Results Summary pane using the keyboard or Ul
buttons. Both means of navigation respect the grouping, filters, and methodology used
to display results.

Comparison with R2013a Polyspace products

Polyspace Code Prover is a single product that replaces the following R2013a products:

* Polyspace Client™ for C/C++
* Polyspace Server™ for C/C++

Polyspace Bug Finder, which is available with the Polyspace Code Prover, incorporates
the following R2013a products:

*  Polyspace Model Link™ SL
*  Polyspace Model Link TL
* Polyspace UML Link™ RH

For a summary of differences and similarities in remote verification, results review and
other features and options, expand the following:

Remote verification

Category R2013a R2013b
Install: Install:
+  Polyspace Client for C/C++ on + MATLAB, Polyspace Bug Finder,
local computer and Parallel Computing Toolbox on
+  Polyspace Server for C/C++ on local computer.
network computers, which are + MATLAB, Polyspace Bug Finder,
Products required configured as Queue Manager and Polyspace Code Prover, and
CPUs. MATLAB Distributed Computing
Server on head node of computer
cluster. For information about
setting up a cluster, see Install
Products and Choose Cluster
Configuration.
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Category

R2013a

R2013b

Configuring and
starting services

On the Polyspace Preferences >
Server Configuration tab:

Under Remote configuration,
specify host computer for Queue
Manager and Polyspace Metrics
server and communication port.

Under Metrics configuration,
specify other settings for
Polyspace Metrics.

On the Polyspace Preferences >
Server Configuration tab:

Under MDCS cluster
configuration, specify computer
for cluster head node, which hosts
the MATLAB job scheduler (MJS).
The MJS replaces the R2013a
Polyspace Queue Manager.

Under Metrics configuration:
+  Specify host computer for

Polyspace Metrics server and
communication port.

+ Specify other settings for
Polyspace Metrics.
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Category

R2013a

R2013b
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In the Remote Launcher Manager
dialog box:

1 Under Common Settings,
specify Polyspace communication
port, user details, and results
folder for remote verifications.

2 Under Queue Manager
Settings, specify Queue
Manager and CPUs.

3 Under Polyspace Server
Settings, specify available
Polyspace products.

4 To start the Queue Manager and

Polyspace Metrics service, click
Start Daemon.

In the Metrics and Remote Server
Settings dialog box:

1 Under Polyspace Metrics
Settings, specify user details,
Polyspace communication port,
and results folder for remote
verifications.

2 Under Polyspace MDCS
Cluster Security Settings, you
see the following options with
default values:

+ Start the Polyspace MDCE
service — Selected. The mdce
service, which is required to
manage the MdJS, runs on the
MJS host computer and other
nodes of the cluster.

+ MDCE service port — 27350.

+ Use secure communication
— Not selected. Communication
is not encrypted. You may
want to use communication
with security. For information
about MATLAB Distributed
Computing Server cluster
security, see Cluster Security.

3 To start the Polyspace Metrics
and mdce services, click Start
Daemon.

Use the Metrics and Remote Server
Settings dialog box to start and stop
mdce services only if you configure
the MDCS head node as the Polyspace
Metrics server. Otherwise, clear the
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Category

R2013a

R2013b

Start the Polyspace MDCE service
check box, and use the MDCS Admin
Center. To open the MDCS Admin
Center, run:

matlabroot/toolbox/distcomp/bin/admincente
For information about the MDCS
Admin Center, see Cluster Processes
and Profiles.

Running a remote
verification

In the Project Manager perspective:

1 On the Configuration >
Machine Configuration pane,
select the following check boxes:

+ Send to Polyspace Server

+ Add to results repository
— Allows viewing of results
through Polyspace Metrics.

2 On the toolbar, click Run.

The Polyspace client performs code
compilation and coding rule checking
on the local, host computer. Then

the Polyspace client submits the
verification to the Queue Manager on
your network.

In the Project Manager perspective:

1 On the Configuration >
Distributed Computing pane,
select the Batch check box. By
default, the software selects the
Add to results repository,
which enables the generation of
Polyspace Metrics.

2 On the toolbar, click Run.

The Polyspace Code Prover software
performs code compilation and
coding rule checking on the local,
host computer. Then the Parallel
Computing Toolbox client submits
the verification job to the MdJS of the
MATLAB Distributed Computing
Server cluster.

Managing remote
verifications

Use the Queue Manager to monitor
and manage submitted jobs from
Polyspace clients.

On the Web, you can monitor jobs
through Polyspace Metrics. If you
have installed Polyspace Server for C/
C++ on your local computer, through
Polyspace Metrics, you can open the
Queue Manager .

Use the Queue Manager to monitor
and manage jobs submitted through
Parallel Computing Toolbox clients.

7-9


http://www.mathworks.com/help/releases/R2013b/mdce/cluster-administration.html
http://www.mathworks.com/help/releases/R2013b/mdce/cluster-administration.html

R2013b

Category

R2013a

R2013b

Accessing results of
remote verifications

When you run a verification on a
Polyspace server, the Polyspace
software automatically downloads the
results to your local, client computer.
You can view the results in the
Results Manager perspective.

In addition, you can use the Queue
Manager to download results of
verifications submitted from other
Polyspace clients.

On the Web, use Polyspace Metrics
to view verification results stored

in results repository. If Polyspace
Client for C/C++ is installed on your
local computer, you can download
verification results. For example,

in Polyspace Metrics, clicking a cell
value in the Run-Time Checks view
opens the corresponding verification
results in the Results Manager.

On the Web, use Polyspace Metrics to
view verification results. If Polyspace
Bug Finder is installed on your

local computer, you can download
verification results. For example, in
Polyspace Metrics, clicking a Project
cell in the Runs view opens the
corresponding verification results in
the Results Manager.

Results review

Category

R2013a

R2013b

Results Explorer

Explorer.

Available. Allows navigation
through checks by the file and
function where they occur.

To view, select Window >
Show/Hide View > Results

Removed. To navigate through
checks by file and function, on
Results Summary pane, from
the drop-down menu, select
File/Function.

Filters on the Results

Summary pane

7-10

can filter by:

*  Coding rules violated

Filters appear as icons on the
Results Summary pane. You

*  Run-time error category

You can filter by the information
in all the columns of the
Results Summary pane. In
addition to existing filters,

the new filtering capabilities
extend to the file, function and
line number where the checks
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Category

R2013a

R2013b

+  Check color

+  Check justification
+  Check classification
*  Check status

appear. You can also define your
own filters.

The filters appear as the = icon
on each column header. To apply
a filter using the information in
a column:

1 Place your cursor on the
column header. The filter
icon appears.

2 Click the filter icon and
from the context menu,
clear the All box. Select the
appropriate boxes to see the
corresponding checks.

For more information, see
Organize Check Review Using
Filters and Groups.

Code Coverage Metrics

In the Results Explorer
view, the software displays two
metrics for the project:

* unp — Number of
unreachable functions as
a ratio of total number of
functions

+ cov — Percentage of
elementary operations
covered by verification

The unreachable procedures
are marked gray in the Results
Explorer view.

The new Results Statistics
pane displays the code coverage
metrics through the Code
covered by verification
column graph.

To see a list of unreachable
procedures, click this column
graph.

For more information, see
Results Statistics.

7-11


http://www.mathworks.com/help/releases/R2013b/codeprover/ug/filter-checks.html
http://www.mathworks.com/help/releases/R2013b/codeprover/ug/filter-checks.html
http://www.mathworks.com/help/releases/R2013b/codeprover/ug/exploring-results-manager-perspective.html#bt1btjh-1

R2013b

Other features

Product Feature R2013a R2013b
Installation Separate installation Polyspace Code Prover
process for Polyspace software installed during
products MATLAB installation
process.
Project On host, for example, On host, using Polyspace
configuration using Polyspace Client |Code Prover software.

Polyspace Client and
Server for C/C++
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for C/C++ software.

Local verification

On host, run Polyspace
Client for C/C++
verification.

Review results in
Results Manager.

On host, run Polyspace
Code Prover verification.

Review results in Results
Manager.

Export of review
comments to Excel,
and Excel report
generation

Supported

Not supported.

Line command

polyspace-c ...

polyspace-cpp --.

polyspace-code-
prover-nodesktop ...

Project project _name.cfg project name.psprj
configuration file

extension

Results file results name.rte results _name.pscp
extension

Configuration Available Replaced by

> Machine Configuration >
Configuration Distributed Computing
pane pane.

Configuration > |Available Renamed Configuration

Post Verification
pane

> Advanced Settings

goto blocks

Not supported

Supported




Reviewing Results

Product Feature R2013a R2013b
Run verifications Supported Not supported, produces a
from multiple license error -4, 0.
Polyspace
environments
Non-official Available in Renamed Other and
options field Configuration moved to Configuration
> Machine > Advanced Settings
Configuration pane pane
Polyspace Model Link |Default includes Includes specific to the |Generic includes for C and
SL and TL target specified. C++. These includes are

target independent.

Running a Code > Polyspace Code > Polyspace >
verification > Polyspace for Verify Code Generated
Embedded Coder/ for
Target Link
+  Selected Subsystem
+ Verify Generated - Model
Code
) Referenced Model
+ Verify Generated )
Model Reference + Selected Target Link
Code Subsystem
Also right-clicking Also right-clicking on a
on a subsystem and subsystem and sel.ectlng
selecting Polyspace Polyspace > Verify
> Polyspace for Code Generated for >
Embedded Coder/ Selected Subsystem/
Target Link Selected Target Link
Subsystem
Product Mode Not available. Choose between Code
Prover or Bug Finder
depending on the type of
analysis you want to run.
Settings Available. Called Available. Called Settings

Verification Settings
from

from. Functionality the
same.
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R2013b

Product

Feature

R2013a

R2013b

Open results

Option Open Project
Manager and Results
Manager opened

the Polyspace Project
Manager.

Option Open results
automatically after
verification opens
Polyspace Metrics (batch
verifications) or Polyspace
Results Manager (local
verifications).

Polyspace plug-in for
Visual Studio 2010

Support for C++11
features

Partial support.

Added support for:

Lambda functions

+  Rvalue references
for *this and
initialization of class
objects by rvalues

+  Decltype

+ Auto keyword for
multi-declarator auto
and trailing return
types

Static assert

*  Nullptr
+  Extended friend
declarations

Local and unnamed
types as template
arguments

Options

Product

Option

R2013a

R2013b

-code-metrics

Available. Not selected
by default.

Removed. Code
complexity metrics
computed by default.
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Reviewing Results

Product Option R2013a R2013b
-dialect Available. Default unchanged,
but new value gnu4 .6
available for C and C++.
-max-processes Specify through Specify from command
Machine line, or through

Polyspace Client and
Server for C/C++

Configuration >
Number of processes
for multiple CPU
core systems or
command line .

Advanced Settings >
Other.

-allow-language-
extensions

Available. Selected by
default.

Removed. By default,
software supports subset
of common C language
constructs and extended
keywords defined by

the C99 standard or
supported by many
compilers.

-enum-type-
definition

Available with three
values. First value
called defined-by-
standard.

Available with three
values.

For C, first value
renamed signed-int.

For C++, first value
renamed auto-
signed-int-first.
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R2013b

behavior wrap-
around

Product Option R2013a R2013b
Polyspace Model Link |-scalar- Available. Not selected |Default.
SL and TL overflows- by default.

This option identifies
generated code from
blocks with saturation
enabled.

However, this option
might lead to a loss of
precision. For models
without saturation, you
can choose to remove
this option.

-ignore-constant-
overflows

Available. Not selected
by default.

Default.
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